Bug 496967 - Udev needs permissions entry for ACM devices.
Udev needs permissions entry for ACM devices.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev (Show other bugs)
4.7
All Linux
low Severity medium
: rc
: ---
Assigned To: Harald Hoyer
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 16:52 EDT by Jonathan Hutchins
Modified: 2011-02-16 09:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the udev package did not contain explicit permission entries for ttyACM devices. Due to this behavior, ttyACM devices were assigned the default permissions, preventing the uucp group from having read/write access. This update adds An explicit permission entry to the udev permission file, to assign ttyACM devices to the uucp group, and the uucp group now has read/write access to ttyACM devices.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-16 09:11:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0232 normal SHIPPED_LIVE udev bug fix update 2011-02-15 11:35:15 EST

  None (edit)
Description Jonathan Hutchins 2009-04-21 16:52:20 EDT
Description of problem: udev lacks a permission entry for ACM devices (typically USB Modems).  /dev/ttyACM* are created with root rw permission only.  Using the standard serial port as an example, they should be root:uucp owner/group rw. (crw-rw----)

This can be corrected by editing /etc/udev/permissions.d/50-udev.permissions

Under the section:

# serial+dialup devices

Using the standard serial ports as an example:
ttyS*:root:uucp:0660

add the following line:

ttyACM*:root:uucp:0660

Version-Release number of selected component (if applicable):

udev-039-10.15.EL4
Comment 5 Florian Nadge 2011-01-12 08:54:24 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:
Comment 6 Harald Hoyer 2011-01-12 09:10:12 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1,15 @@
 Cause:
 
+udev did not contain explicit permission entries for ttyACM devices.
+
 Consequence:
 
+ttyACM devices were assigned the default permissions, preventing the uucp group from having read/write access.
+
 Fix:
 
-Result:+An explicit permission entry was added to the udev permission file, to assign ttyACM devices to the uucp group.
+
+Result:
+
+The uucp group now has read/write access to ttyACM devices.
Comment 7 Florian Nadge 2011-01-13 05:55:25 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,15 +1 @@
-Cause:
+Previously, the udev package did not contain explicit permission entries for ttyACM devices. Due to this behavior, ttyACM devices were assigned the default permissions, preventing the uucp group from having read/write access. This update adds An explicit permission entry to the udev permission file, to assign ttyACM devices to the uucp group, and the uucp group now has read/write access to ttyACM devices.-
-udev did not contain explicit permission entries for ttyACM devices.
-
-Consequence:
-
-ttyACM devices were assigned the default permissions, preventing the uucp group from having read/write access.
-
-Fix:
-
-An explicit permission entry was added to the udev permission file, to assign ttyACM devices to the uucp group.
-
-Result:
-
-The uucp group now has read/write access to ttyACM devices.
Comment 8 errata-xmlrpc 2011-02-16 09:11:52 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0232.html

Note You need to log in before you can comment on or make changes to this bug.