Bug 496979 - Weird behaviour for both traceroute and the host command
Weird behaviour for both traceroute and the host command
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: traceroute (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 17:43 EDT by Jóhann B. Guðmundsson
Modified: 2009-04-21 18:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 18:20:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output of traceroute login.facebook.com (120.06 KB, application/octet-stream)
2009-04-21 17:43 EDT, Jóhann B. Guðmundsson
no flags Details
strace output of traceroute facebook.com for comparison (109.47 KB, application/octet-stream)
2009-04-21 17:44 EDT, Jóhann B. Guðmundsson
no flags Details
strace output of host login.facebook.com (46.54 KB, application/octet-stream)
2009-04-21 17:45 EDT, Jóhann B. Guðmundsson
no flags Details
strace output of host facebook.com for comparison (39.99 KB, application/octet-stream)
2009-04-21 17:47 EDT, Jóhann B. Guðmundsson
no flags Details
time dig output (3.28 KB, text/plain)
2009-04-21 17:48 EDT, Jóhann B. Guðmundsson
no flags Details
time ping output (787 bytes, text/plain)
2009-04-21 17:48 EDT, Jóhann B. Guðmundsson
no flags Details
time host output (496 bytes, text/plain)
2009-04-21 17:49 EDT, Jóhann B. Guðmundsson
no flags Details
time traceroute output (3.17 KB, text/plain)
2009-04-21 17:52 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2009-04-21 17:43:03 EDT
Created attachment 340634 [details]
strace output of traceroute login.facebook.com

Description of problem:

I've been experiencing time outs while trying to connect to login.facebook.com
and some other sites.. ( seems to be site or fqdn specific ) 

Now both traceroute and the host command seem to be affected by this well odd behaviour which suggest some common element they both use ( not traceroute nor the host command ) and hopefully we can flush this bug out in the open.. 

When I run traceroute login.facebook.com it takes traceroute about 20 to 25
seconds to display the the first ( 1 ) entry vs it works immediately when running traceroute facebook.com.

When running host login.facebook.com it shows the ip address for login.facebook.com then errors out with 
";; connection timed out; no servers could be reached"

Now ping and dig response very well.. 

Version-Release number of selected component (if applicable):

latest rawhide as of the date filing this bug.

How reproducible:

Always when running traceroute login.facebook.com and host login.facebook.com

Steps to Reproduce:
1. the above.
2.
3.
  
Actual results:

Weirdness 

Expected results:

Happyness 

Additional info:
Comment 1 Jóhann B. Guðmundsson 2009-04-21 17:44:59 EDT
Created attachment 340636 [details]
strace output of traceroute facebook.com for comparison
Comment 2 Jóhann B. Guðmundsson 2009-04-21 17:45:53 EDT
Created attachment 340637 [details]
strace output of host login.facebook.com
Comment 3 Jóhann B. Guðmundsson 2009-04-21 17:47:04 EDT
Created attachment 340639 [details]
strace output of host facebook.com for comparison
Comment 4 Jóhann B. Guðmundsson 2009-04-21 17:48:02 EDT
Created attachment 340640 [details]
time dig output
Comment 5 Jóhann B. Guðmundsson 2009-04-21 17:48:35 EDT
Created attachment 340641 [details]
time ping output
Comment 6 Jóhann B. Guðmundsson 2009-04-21 17:49:14 EDT
Created attachment 340642 [details]
time host output
Comment 7 Jóhann B. Guðmundsson 2009-04-21 17:52:58 EDT
Created attachment 340643 [details]
time traceroute output
Comment 8 Jóhann B. Guðmundsson 2009-04-21 17:56:55 EDT
Oh yeah I forgot.. 

http://www.smolts.org/client/show/pub_29f00f44-9a40-4e29-84d5-75fedd098e35
Comment 9 Jóhann B. Guðmundsson 2009-04-21 18:20:30 EDT
Duplicated on Debian and f10 looks like it's an broken dns setup on facebooks half.. Closing..

Note You need to log in before you can comment on or make changes to this bug.