Bug 496997 - the src.rpm can't be rebuild
the src.rpm can't be rebuild
Status: CLOSED DUPLICATE of bug 456814
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libwvstreams (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 18:59 EDT by Levente Farkas
Modified: 2009-04-23 02:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 02:58:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2009-04-21 18:59:32 EDT
this src.rpm can't be rebuild on 5.3 because of this error:

g++ -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC -D_BSD_SOURCE -D_GNU_SOURCE -DISLINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g -DDEBUG=0  -O2 -Wall -Iyes/include -I./xplc/include  -I./include -Iinclude -Iinclude -Ignulib -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g -O2 -Wall -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC -D_BSD_SOURCE -D_GNU_SOURCE -DISLINUX -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g -DDEBUG=0 -O2 -Wall -Woverloaded-virtual -fno-rtti -fno-exceptions -Iyes/include -I./xplc/include  -I./include -Iinclude -Iinclude -Ignulib -pipe -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -fPIC -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -g -O2 -Wall -Woverloaded-virtual -DWVSTREAMS_RELEASE=\"4.2.2\"     -c utils/wvvector.cc -o utils/wvvector.o
./include/wvvector.h: In member function 'T* WvVector<T>::Iter::ptr() const':
./include/wvvector.h:361: error: there are no arguments to 'cur' that depend on a template parameter, so a declaration of 'cur' must be available
./include/wvvector.h:361: error: (if you use '-fpermissive', G++ will accept your code, but allowing the use of an undeclared name is deprecated)
./include/wvvector.h: In member function 'bool WvVector<T>::Iter::get_autofree() const':
./include/wvvector.h:371: error: 'link' was not declared in this scope
./include/wvvector.h: In member function 'void WvVector<T>::Iter::set_autofree(bool)':
./include/wvvector.h:379: error: 'link' was not declared in this scope
./include/wvvector.h: In member function 'void WvVector<T>::Iter::remove(bool)':
./include/wvvector.h:389: error: 'i' was not declared in this scope
./include/wvvector.h: In member function 'void WvVector<T>::Iter::xremove(bool)':
./include/wvvector.h:407: error: 'i' was not declared in this scope
./include/wvvector.h:408: error: there are no arguments to 'prev' that depend on a template parameter, so a declaration of 'prev' must be available
make: *** [utils/wvvector.o] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.17838 (%build)
Comment 1 Ondrej Vasik 2009-04-22 14:50:00 EDT
Already reported against Fedora and fixed there, see https://bugzilla.redhat.com/show_bug.cgi?id=224168 for patch.
Comment 2 Levente Farkas 2009-04-22 16:54:24 EDT
but for rhel 5.3 will it be fixed? any updated src.rpm for rhel?
Comment 3 Levente Farkas 2009-04-22 17:19:14 EDT
anyway the patch is working.
Comment 4 Ondrej Vasik 2009-04-23 02:53:43 EDT
Once the update for libwvstreams will be approved and scheduled for RHEL-5, it will get fixed, it's easy... however there are so many components in RHEL - so the chance it will get fix in RHEL-5 soon is not very high. It could be increased via product support for RHEL - bugzilla is not product support - it's just bug reporting tool.
Comment 5 Ondrej Vasik 2009-04-23 02:58:13 EDT
Aaah, I see there is already duplicate of this... missed it somehow - so closing that one as DUPLICATE.

*** This bug has been marked as a duplicate of bug 456814 ***

Note You need to log in before you can comment on or make changes to this bug.