Bug 497046 - Regression e1000 card is not appearing up after update to 2.6.9-78.0.13.ELsmp
Regression e1000 card is not appearing up after update to 2.6.9-78.0.13.ELsmp
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Michal Schmidt
Red Hat Kernel QE team
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 02:50 EDT by Wade Mealing
Modified: 2013-01-10 21:30 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 10:34:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wade Mealing 2009-04-22 02:50:08 EDT
Description of problem:

e1000 card that comes up and works on boot in in 2.6.9-55, no longer works correctly in  2.6.9-78.0.13.ELsmp

Version-Release number of selected component (if applicable):

2.6.9-78.0.13.ELsmp

How reproducible:

Every time

Steps to Reproduce:
1. Have a working system running 2.6.9-55
2. Update to  2.6.9-78.0.13.ELsmp 
3. Reboot
  
Actual results:

The card will not function (accept/transmit) packets. An ifconfig down ifconfig up will solve the problem.


Expected results:

Card to work correctly.

Additional info:

The card using the e1000 (not e1000e) driver.
Comment 4 Prarit Bhargava 2009-04-22 09:07:47 EDT
Setting Regression flag.  This may be a blocker -- this worked in an earlier release and no longer works.

P.
Comment 6 Michal Schmidt 2009-04-22 10:09:22 EDT
2.6.9-55 was the kernel from RHEL 4.5.
2.6.9-78.0.13 is from RHEL 4.7.z

To narrow the problem down at least a little bit, could you please try the kernel from RHEL 4.6 (ie. 2.6.9-67)?

Meanwhile I'll see if there are any hints in the sosreport. Can we also have a sosreport from the working kernel version?
Comment 7 Michal Schmidt 2009-04-22 12:04:54 EDT
Not reproducible on hp-dl360g5-01.rhts.bos.redhat.com which contains the same PCI ID:

Linux hp-dl360g5-01.rhts.bos.redhat.com 2.6.9-78.0.13.ELsmp #1 SMP Wed Jan 7 17:45:52 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

0b:00.0 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
0b:00.1 Ethernet controller: Intel Corporation 82571EB Gigabit Ethernet Controller (rev 06)
0b:00.0 Class 0200: 8086:105e (rev 06)
0b:00.1 Class 0200: 8086:105e (rev 06)
Comment 8 Michal Schmidt 2009-04-22 12:50:07 EDT
I uploaded six older versions of the e1000 driver to http://michich.fedorapeople.org/bz497046/

I suggest you download them all and try them one by one with the kernel you have.
For example for the first one:

# overwrite the e1000.ko module with the testing one
cp e1000-2.6.9-55.20.ELsmp.ko /lib/modules/2.6.9-78.0.13.ELsmp/kernel/drivers/net/e1000/e1000.ko
Then reboot and see if it works or not.
Repeat for the other ones.

This should help find which change caused the regression.
Thanks.
Comment 12 Michal Schmidt 2009-04-24 11:41:13 EDT
Hello,
do we have any of the results yet? Since this can be a blocker, it's quite urgent to have it fixed.
Michal
Comment 13 Michal Schmidt 2009-04-27 06:51:20 EDT
There have been several changes in e1000 in RHEL4.8, so it would be nice to test if it happens with 4.8 kernel too:
http://people.redhat.com/vgoyal/rhel4/RPMS.kernel/
Comment 18 Chris Ward 2009-05-12 10:34:41 EDT
Customer not responding. Closing as NOTABUG. If this issue comes up again, please re-open.

Note You need to log in before you can comment on or make changes to this bug.