Bug 49707 - Unable to telnet. The telnet server is not responding.
Unable to telnet. The telnet server is not responding.
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-07-23 09:52 EDT by Michael Colef
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-24 09:43:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Colef 2001-07-23 09:52:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.6-2 i686)

Description of problem:

I have a small network with a Linux server and two Windows clients (my
kids computers) and one Linux client (my laptop).

I have installed RH 7.1 in Custom-Class installation choosing everything
on my server and my laptop. The installation was done in text mode and
went on without any problems on the server. I did the same thing on the
laptop except in graphic mode and everything went on without any
problem. After the installation I went into /etc/xinetd.d and edited the
telnet script to enable the service. I used "chkconfig telnet on"
command to add the telnet service. I restarted xinetd and tried to
telnet into the server from my laptop but I got the message:
"Trying ...
telnet: Unable to connect to the remote host: Connection refused".

I logged into my server as another user (NOT ROOT) and I had the same
experience. I then started, as root, the telnet server in debug mode. I
used "in.telnetd -debug" command and surprise, I was able to telnet into
my server. But of course when I logged off and tried to login again I
could not. Something very interesting is that I can telnet into my web
server using "telnet www 80" and it works. 

I also tried "netstat -an | grep 23" but no telnet server listening to port
23 was on the list. I mean I did not get something like:

tcp        0      0    *               LISTEN

I have both DNS and NIS. I pinged all the computers on the network and
they all responded. I did nslookup and got the correct names and
addresses for all the computers on the network. The firewall is not
enabled. I even tried "/etc/rc.d/init.d/ipchains stop" and the same thing
with itpables. Then I tried to telnet, but to no avail. 

There are no error mesages in the /var/log/messages either.

How reproducible:

Steps to Reproduce:
1.telnet to the machine

Actual Results:  It does not connect to the host.

Additional info:
Comment 1 Harald Hoyer 2001-07-23 10:14:21 EDT
sorry... works for me... seems, as if xinetd is not started or port 23 was 
already in use at xinetd startup time... 
# rpm -q xinetd
# rpm -ivh .../dist/7.1/telnet/0.17-10/i386/telnet-server-0.17-10.i386.rpm
# rpm -q telnet-server
# chkconfig telnet on
# service xinetd reload
Reloading configuration:                                   [  OK  ]
# lsof -i -n|fgrep telnet
xinetd      659   root    4u  IPv4   1376       TCP *:telnet (LISTEN)
# netstat -tunl|fgrep 23
tcp        0      0    *               LISTEN
# ssh harald@mail
[harald@bochum harald]$ telnet faro
Connected to faro.stuttgart.redhat.com (
Escape character is '^]'.
Red Hat Linux release 7.0 (Guinness)
Kernel 2.4.2-2 on an i686

Comment 2 Michael Colef 2001-07-23 10:42:00 EDT
I mentioned that I restarted xinetd after enabling telnet service. I also
checked that xinetd was started. There goes the first explanation. 

I also mentioned that I checked port 23 but there is nothing there. I tried both
before and after restarting xinetd. Besides, telnet works in debug mode. I think
it is using that same port 23, isn't it? There goes the second explanation.

Do you have any other suggestions of what might be wrong? I am trying to solve
this problem for the past three weeks. Why is telnet working on my laptop and my
desktop at work with the same installation, except they are not configured as
DNS or NIS servers, and it is not working on my server at home? It is really
Comment 3 Harald Hoyer 2001-07-23 10:50:05 EDT
restarted xinetd without the nameserver entry in /etc/resolv.conf -> works also
# netstat -tunl|fgrep 23
tcp        0      0    *               LISTEN

Maybe you forgot the -l in your netstat options. Is s.th. in 
Comment 4 Michael Colef 2001-07-24 09:38:28 EDT
I have checked using "netstat -tunl|fgrep 23" and there is nothing listening to
port 23. If I start the telnet server in debug mode using "in.telnetd -debug"
and use the "netstat -tunl|fgrep 23" command, then I get "tcp        0      0    *               LISTEN". 

I restarted xinetd and checked that xinetd was started and it was because it
gave me something of this form:
root       735  0.0  0.3  2252  888 ?        S    09:22   0:00 xinetd -stayalive
-reuse -pidfile /var/run/xinetd.pid

I checked the /var/log/messages for the s.th. and ther is nothing like that in
there, but there is nothing like that in the /var/log/messages of the other two
computers that I have and run RH 7.1 and telnet works on.

You mentioned something about port 23 being busy when xinetd is started. But I
think that the netstat command that I used and you suggested should show that.
What could be keeping port 23 busy and not show up?
Comment 5 Harald Hoyer 2001-07-24 09:41:33 EDT
Well, then this is an xinetd problem... 
Comment 6 Trond Eivind Glomsrxd 2001-07-31 17:02:17 EDT
I've tested this quite a few times, and this doesn't happen. I've never seen any
reports of it happening. Run "chkconfig telnet on", "service xinetd reload".
Look for messages containing telnet in the logs - telnet should be mentioned
even if it is disabled.

Comment 7 Kenny Dubuisson, Jr. 2001-08-30 14:30:44 EDT
I have the same problem and I have worked with a RedHat engineer to verify.  
Can I reopen this work order?
Comment 8 Trond Eivind Glomsrxd 2001-08-30 14:41:36 EDT
If you can convince me there is a problem in xinetd... I've tested this many
times myself without this or other problems happening.

There are some standard causes for this:

1) The telnetserver isn't turned on or installed
2) xinetd hasn't reloaded its configuration since telnet was turned on
3) DNS misconfiguration, so the server can't look up the connecting client. When
that happens, it will drop the connection.

Note You need to log in before you can comment on or make changes to this bug.