This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 497079 - heartbeat-gui missing dependencies [NEEDINFO]
heartbeat-gui missing dependencies
Status: CLOSED EOL
Product: Fedora EPEL
Classification: Fedora
Component: heartbeat (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 05:59 EDT by Arnaud Gomes-do-Vale
Modified: 2017-04-06 06:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-06 06:37:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tremble: needinfo? (arnaud.gomes)


Attachments (Terms of Use)

  None (edit)
Description Arnaud Gomes-do-Vale 2009-04-22 05:59:00 EDT
Description of problem:

heartbeat-gui is missing dependencies. It won't run unless you manually install pygtk2-libglade and dejavu-fonts.


Version-Release number of selected component (if applicable):

heartbeat-gui-2.1.4-6.el5


How reproducible:

Always.


Steps to Reproduce:
1. start from clean install of CentOS,
2. run hb_gui

  
Actual results:

Without libglade:

[root@rose ~]# hb_gui
Traceback (most recent call last):
  File "/usr/bin/hb_gui", line 41, in ?
    import gtk, gtk.glade, gobject
ImportError: No module named glade

Without dejavu-fonts:

[root@rose ~]# hb_gui
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual
page and on http://fontconfig.org


Expected results:

hb_gui starts properly.
Comment 1 BJ Dierkes 2009-04-22 19:29:17 EDT
The main heartbeat package is also missing a BuildRequires for zlib-devel.

gcc -shared  .libs/zlib.o -Wl,--whole-archive ../../../replace/.libs/libreplace.a -Wl,--no-whole-archive  -lz -lbz2 -lxml2 -lc -lpam -lrt -ldl /usr/lib64/libltdl.so  -m64 -mtune=generic -m64 -mtune=generic -Wl,-soname -Wl,zlib.so -o .libs/zlib.so
/usr/bin/ld: skipping incompatible /usr/lib/libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /usr/lib/libz.a when searching for -lz
/usr/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
gmake[4]: *** [zlib.la] Error 1
Comment 2 Kevin Fenzi 2009-04-24 18:38:33 EDT
Humm. 

>1. start from clean install of CentOS,
>2. run hb_gui

Did you install heartbeat from CentOS or from EPEL? 
Note that there are CentOS packages in the extras repo. 

rpm -qa | grep heartbeat 

returns what?
I will look at duplicating this here. 

> The main heartbeat package is also missing a BuildRequires for zlib-devel.

Odd. This gets pulled in on a mock build here. 
I can add it in easily enough tho.
Comment 3 Kevin Fenzi 2009-04-24 18:54:31 EDT
I can confirm that pygtk2-libglade is needed. 
On the font it doesn't seem to need dejavu, it just needs any font I think. Not sure how to specify this... will dig into the glade and see if I can see what it's looking for exactly.
Comment 4 Kevin Fenzi 2009-05-05 18:39:28 EDT
So, to clarify, what fonts packages did you have installed? any? 
I'm not sure how to express the font dependency here... it's basically happy to use most anything it can find. ;(
Comment 5 Kevin Fenzi 2009-06-12 13:31:02 EDT
Can you please test: 
http://buildsys.fedoraproject.org/plague-results/fedora-5-epel/heartbeat/2.1.4-8.el5/

It should fix all the issues except the font one. 
(Not at all sure how to address that one). 

let me know if the other items are fixed.
Comment 6 Arnaud Gomes-do-Vale 2009-06-23 11:30:51 EDT
On a host with the font issue:

[root@inpace ~]# rpm -qa|grep -i font
libXfont-1.2.2-1.0.3.el5_1
xorg-x11-font-utils-7.1-2
chkfontpath-1.10.1-1.1
libfontenc-1.0.2-2.2.el5
fontconfig-2.4.1-7.el5
xorg-x11-fonts-ISO8859-1-75dpi-7.1-2.1.el5

So I have at least basic fonts installed.
Comment 7 Kevin Fenzi 2009-06-28 15:30:56 EDT
Can you install xorg-x11-fonts-base and see if that gets it working? 
Also, can you confirm the other issues are fixed?
Comment 8 Kevin Fenzi 2009-07-11 00:25:21 EDT
Any chance to try the item from comment #7?
Comment 9 Arnaud Gomes-do-Vale 2009-07-11 05:51:45 EDT
No, xorg-x11-fonts-base is not enough, even in addition to what I had previously installed, I still get the same error message about missing fonts.
Comment 10 Kevin Fenzi 2009-09-26 17:05:26 EDT
Can you try 'bitmap-fonts' ?

I will try and setup a minimal install here were I can try and track this down more closely so I don't have to keep bugging you. :)
Comment 11 Fedora End Of Life 2017-04-06 06:37:24 EDT
Fedora EPEL 5 changed to end-of-life (EOL) status on 2017-03-31. Fedora EPEL 5
is no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of Fedora
or Fedora EPEL, please feel free to reopen this bug against that version. If
you are unable to reopen this bug, please file a new report against the current
release. If you experience problems, please add a comment to this bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.