Bug 497144 - missing dependencies
missing dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 10:11 EDT by Marcela Mašláňová
Modified: 2009-04-22 10:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 10:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2009-04-22 10:11:07 EDT
Description of problem:
Update from F-10 minimal installation to rawhide hangs. It could be problem of dependencies defined in this package.

Version-Release number of selected component (if applicable):
xorg-x11-drivers-7.3-9.fc10.i386

How reproducible:
Have F-10 i386 with minimal install and try to update to rawhide.

Steps to Reproduce:
1. yum update rpm
  
Actual results:
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
xorg-x11-drv-calcomp is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-citron is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-diamondtouch is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-digitaledge is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-dmc is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-dynapro is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-jamstudio is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-magellan is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-microtouch is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-palmax is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-spaceorb is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-summa is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-tek4957 is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-ur98 is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
xorg-x11-drv-wiimote is needed by (installed) xorg-x11-drivers-7.3-9.fc10.i386
Complete!
(1, [u'Please report this error in bugzilla'])


Expected results:
Update pass.

Additional info:
Comment 1 Adam Jackson 2009-04-22 10:53:08 EDT
It's clear that the update is trying to pull in an updated xorg-x11-server package, which Obsoletes those drivers (since they're deprecated).  It's not at all clear _why_ the new server package is being pulled in.  But I suppose the obvious thing is to make the server package also Conflict with too old versions of xorg-x11-drivers.

Fixed in 1.6.1-7, building now.

Note You need to log in before you can comment on or make changes to this bug.