Bug 497184 - [LTC 6.0 FEAT] Task consolidation across nodes for single board NUMA machines [201927]
[LTC 6.0 FEAT] Task consolidation across nodes for single board NUMA machines...
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
low Severity high
: rc
: 6.0
Assigned To: John Feeney
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 525727
  Show dependency treegraph
 
Reported: 2009-04-22 13:40 EDT by IBM Bug Proxy
Modified: 2013-01-10 02:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 15:10:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 52946 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-04-22 13:40:43 EDT
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201927]
a. Name of Feature:	Task consolidation across nodes for single board NUMA machines
b. Feature Description
This patch series that extends the existing sched_smt_/mc_power_savings framework to work on
platforms that have on-chip memory controllers making each of the cpu-package a 'node'.  This
applies to Nehalem based hardware architectures.

2. Feature Details:
Sponsor:	Linux Systems Tech
Architectures:
x86_64
ppc64

Arch Specificity: Purely Common Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	Submitted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	Patch and discussions: (Version 3)
 http://lkml.org/lkml/2009/3/6/23

3. Business Case
To improve energy management on numa systems

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):

Vaidyanathan Srinivasan, svaidyan@in.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com
Comment 1 IBM Bug Proxy 2009-05-20 02:21:08 EDT
------- Comment From svaidyan@in.ibm.com 2009-05-20 02:11 EDT-------
Code posted and reviewed in LKML

http://lwn.net/Articles/322403/
Comment 2 Matthew Garrett 2009-09-15 09:55:05 EDT
There doesn't appear to have been any discussion of the patches since March, and they're not upstream yet. Does IBM plan to push these?
Comment 3 IBM Bug Proxy 2009-09-30 14:51:19 EDT
------- Comment From sglass@us.ibm.com 2009-09-30 14:46 EDT-------
Since we have been able to get these patches upstream, deferring to RHEL 6.1
Comment 4 John Jarvis 2009-09-30 15:10:35 EDT
Setting as CLOSED DEFERRED to match IBM status.

Note You need to log in before you can comment on or make changes to this bug.