Bug 49723 - Feature Addtion requests for Red Hat 7.3
Feature Addtion requests for Red Hat 7.3
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-23 11:29 EDT by Arion Blishen
Modified: 2009-06-12 08:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-19 03:05:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arion Blishen 2001-07-23 11:29:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Win98; U)

Description of problem:
Can there be an option in RH 7.2 to configure Linux as an Internet Gateway using IPTables and an wizzard to configure the Firewall, Dialup, 
xDSL, Sattelite, cable etc connections

Also can the following be included in RH7.2

* LVM, RAID and Journeling File Sysytems support at install time

* Downloader for X  -  http://www.krasu.ru/soft/chuchelo/
       A downloader client like GetRight

* Better Multimedia players like Xine  http://xine.sourceforge.net/  and VideoLan http://www.videolan.org/

* Ximian GNOME

* Support for Microsoft Internet Keyboard and Microsoft IntelliMice with extra button. Now part of XFree 4.1.0 and/or http://ypwong.org/hotkeys/

* An Option at install time to install programs like RealPlayer 8, Adobe Acrobat, OpenOffice, Macromedia Shockwave and Flash, WinModem 
Drivers and NVidia Drivers

* BlueFish HTML Editor http://bluefish.openoffice.nl/

* More options in Anaconda like starting linux in graphics mode by adding vga=791 to lilo.conf

* More configuration tools and more cetralised tools for easy configuration after installation

Thanks.

How reproducible:
Always

Steps to Reproduce:
1.N/A
2.
3.
	

Additional info:
Comment 1 Alexei Podtelezhnikov 2001-07-24 11:19:22 EDT
In my opinion, the number of necessary clicks/options during instalation in RH 
7.1 is close to optimal. I would work on reducing this number further though. 
For example no one needs to chose video resolution at install time. As long as 
X can come up with a reasonable resolution, it is fine. Network set up is 
unnecessary and can be done later. Well, if it's a network instalation, then it 
makes sense to ask about IP, otherwise it's a bloat. Even Windows also require 
some futher adjustments as a customer wishes later.  

Today the smallest setup, Workstation, is ~1.3 Gb. This is way too large. CD 
copying takes 20 minutes. It can be reduced to under 10 minutes. This is way 
way to go in my opinion. Why would one need KOffice in KDE by default? There 
are many examples like that. As a result of instalation the customer should 
only get his hardware working in full power and configuration tools. If he has 
ethernet card, get him on the internet with basic services like (ping, ftp, 
telnet, ssh). Sound card - set up his drivers and mpg123 at most. And so on.. 
along these lines. Since RH 7.x RH needs to switch CDs - it's a good indication 
that you reached the bloat point.

I'm not against multiple CDs. it's fine to have 10 or more, as long as the 
navigation system is there. On the Application CD(s), offer him a bunch of 
software with a good navigation system by topic: browsers, ftp clients, office, 
software development. You have PowerTools; right now it'a a pile of software 
with very poor navigation; this is useless.
Comment 2 Brent Fox 2002-06-04 12:15:21 EDT
I've assigned this bug to myself, as I plan to fix some of these for the next
release.  There's a bunch of requests rolled into one report here, but I'll fix
most of them.
Comment 3 Brent Fox 2002-06-04 12:17:13 EDT
From some of the issues listed above:

- LVM, RAID and Journeling File Sysytems support at install time

    RAID and ext3 are already in the installer now.  LVM coming soon.

Comment 4 Brent Fox 2002-06-04 12:23:19 EDT
* Better Multimedia players like Xine  http://xine.sourceforge.net/ and VideoLan
http://www.videolan.org/

   - Xine is in 7.3.  Don't know about VideoLan.  Probably a no.

* Ximian GNOME

   - Not going to happen.  There's nothing wrong with regular old Gnome.

* Support for Microsoft Internet Keyboard and Microsoft IntelliMice with extra
button

   - Hard to say.  I'll have to investigate whether we can detect the extra
buttons on USB devices.

* An Option at install time to install programs like RealPlayer 8, Adobe
Acrobat, OpenOffice, Macromedia Shockwave and Flash, WinModem 
Drivers and NVidia Drivers

    - Nope.  Binary only.  No can do.

* BlueFish HTML Editor http://bluefish.openoffice.nl/

    - The mozilla editor and Quanta should suffice.  We can only ship so many
apps that do the same thing.

* More options in Anaconda like starting linux in graphics mode by adding
vga=791 to lilo.conf

     - I think that would be confusing.  In 7.2, we switched anaconda to use
framebuffer mode by default, and it seemed to remove a lot of the video card
issues, so I don't know that this is an issue anymore.

* More configuration tools and more cetralised tools for easy configuration
after installation

     - We have added tools to every release and with 7.2, there was a
centralized place for them in the Nautilus "Start-Here" screen.  There will be
more config tools in the future.
Comment 5 Arion Blishen 2002-06-07 13:44:38 EDT
Some of the stuff above has already been done in RH 7.3 BUT the following stuff
is easy to do for Red Hat in the distro but a pain for the user to do after
install. Also I have listed some additions needed to RH 7.3

* DVB-s card support Satellite TV and Internet (easy for Red Hat to do) I have
already submitted this one to bugzilla

* All the Mouse and Keyboard support in most cases like MS Intellimice and
Internet Keyboards is just adding the option to anacoda and the after install
config tools. XFree86 4.2.0 has support for them just edit the config file
XFree86-4 Device section

As for Red Hat GNOME vs Ximian GNOME. Red Hat GNOME needs to be way better
organised as Red Hat do not put enough effort into it and mainly consentrate on
making the server distro and not the desktop distro which is what Ximian do.
having Ximian GNOME would save Red Hat the effort and cost!
Comment 6 Arion Blishen 2002-06-07 13:47:20 EDT
And update some packages more often like Mozilla, xawtv, xine, etc !
Comment 7 Brent Fox 2002-06-16 12:26:54 EDT
* DVB-s card support Satellite TV and Internet (easy for Red Hat to do) I have
already submitted this one to bugzilla

I don't know much about this one.  What bugzilla number is it?

* All the Mouse and Keyboard support in most cases like MS Intellimice and
Internet Keyboards is just adding the option to anacoda and the after install
config tools. XFree86 4.2.0 has support for them just edit the config file
XFree86-4 Device section

Yes, we're working on new mouse and keyboard tools, so this should get better in
the next release.  I can't promise that all keyboard's internet key thingys will
work because I don't have all that many to test with.

* As for Red Hat GNOME vs Ximian GNOME. Red Hat GNOME needs to be way better
organised as Red Hat do not put enough effort into it and mainly consentrate on
making the server distro and not the desktop distro which is what Ximian do.
having Ximian GNOME would save Red Hat the effort and cost!

To be honest, I don't know why people say that Red Hat doesn't care about the
desktop and only cares about the server.  We have an entire team of people
focusing on desktop issues.  Most of the core GTK+ developers work for us. 
Three of the 11 members of the Gnome Foundation Board of Directors work for us
(http://mail.gnome.org/archives/foundation-announce/2001-November/msg00037.html) 

We are just as involved as anybody in Gnome development, so I disagree that Red
Hat doesn't care about the desktop.  As for using Ximian instead of rolling our
own Gnome, that's just not going to happen.  There are a number of reasons for
that, but trust me on this one.  Red Hat is affected by the direction that Gnome
takes and it would irresponsible for us to leave that direction up to a separate
company that we have no control over.  What if their release cycle wasn't in
sync with ours?  What could we do about it?  What if Ximian goes out of business
or gets acquired by someone else that may not have Red Hat's best interests in
mind?  We would be in a bad spot, and we just can't allow that to happen.

* And update some packages more often like Mozilla, xawtv, xine, etc !

What do you mean by "update"?  Do you mean update them for the next release or
update them on the web in between releases?  As far as I know, Rawhide is the
place to get the latest package updates from Red Hat.  Is that what you're
talking about?
Comment 8 Arion Blishen 2002-06-19 03:04:56 EDT
The Bugizilla number for DVB-s is 63054

There is a lot of info on getting the DVB-s card and VDR and Software CAM going
in the Linux DVB-Sat-TV at HappySat Forum below

http://tforums.com/happysat/viewforum.php?f=17

The packages in RawHide like Mozilla are not updated enough Mozilla in Rawhide
is 4 version old since 0.99 there has been 1.0RC1,2,3 and 1.0 and now 1.1alpha.
Comment 9 Brent Fox 2002-06-19 08:31:10 EDT
I see what you mean about Mozilla in Rawhide.  I don't own any of the packages
you are talking about, so I'm not the one to help you, I guess.  What I'd
recommend is filing a new bug report for every package you'd like to see updated
more often.  That way, the individual owners of those packages can respond. 
That's the best thing to do, since I can't really break this bug report up into
different reports.

I'm going to close this report now since there's not much left on the list that
I can help you with.  You have some good recommendations and I appreciate your
input.  Thanks for your report.
Comment 10 Neil Horman 2009-06-12 08:02:05 EDT
*** Bug 505500 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.