Bug 497236 - Palimpsest notification not placed correctly
Palimpsest notification not placed correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: DeviceKit-disks (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 18:22 EDT by Michael Monreal
Modified: 2009-05-11 21:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 21:16:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (14.49 KB, image/png)
2009-04-22 18:42 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-04-22 18:22:27 EDT
The "drive failing" notification from palimpsest points to the start menu instead of the actual notification icon. This is bad because the bubble text says to click "the icon" to get more information (it means the tray icon).

I guess the problem is that the notifiaction is fired before the panel is shown. Maybe there's a way to make sure the panel is completely shown before trying to show a notification?
Comment 1 Michael Monreal 2009-04-22 18:42:59 EDT
Created attachment 340845 [details]
Screenshot
Comment 2 Matthias Clasen 2009-04-23 13:45:40 EDT
I've put an untested patch here: http://bugzilla.gnome.org/show_bug.cgi?id=579997
Comment 3 Yul Rottmann 2009-05-03 08:48:44 EDT
Okay, in gnome it is fixed, is there a chance that the fix will still go into this fedora release?
Comment 4 Matthias Clasen 2009-05-03 11:34:17 EDT
It will certainly appear in an update. Not sure if it will go in before release.
Comment 5 Matthias Clasen 2009-05-11 21:16:26 EDT
The fix is included in 0.3, which was tagged for F11

Note You need to log in before you can comment on or make changes to this bug.