Bug 497244 - possible bug in turbogears/python
possible bug in turbogears/python
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pylons (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kyle VanderBeek
Fedora Extras Quality Assurance
:
Depends On: 494886
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 19:19 EDT by Itamar Reis Peixoto
Modified: 2009-08-07 00:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.9.7-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-07 00:55:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itamar Reis Peixoto 2009-04-22 19:19:18 EDT
Description of problem:


I am running lasted f11 


I am trying to learn turbogears, 

1 -  tg-admin quickstart hello
2 -  cd hello ; ./start-hello.py


but something seems to be wrong, and doesn't work, I am unable to see anything in http://localhost:8080


Can you take a look in logs below 

 


[itamar@localhost tg]$  tg-admin quickstart hello
/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/lib/cptools.py:3: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5                                                                                                                                              
/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/filters/sessionfilter.py:33: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha                                                                                                                                                                    
/usr/lib/python2.6/site-packages/peak/rules/indexing.py:220: DeprecationWarning: object.__new__() takes no parameters                                                           
  return super(BitmapIndex, cls).__new__(cls, engine, expr)                                                                                                                     
/usr/lib/python2.6/site-packages/sqlobject/converters.py:165: DeprecationWarning: the sets module is deprecated                                                                 
  from sets import Set, ImmutableSet                                                                                                                                            
/usr/lib64/python2.6/site-packages/dispatch/predicates.py:379: DeprecationWarning: object.__new__() takes no parameters                                                         
  return ExprBase.__new__(klass,function,*argexprs)                                                                                                                             
/usr/lib/python2.6/site-packages/tw/core/view.py:202: DeprecationWarning: object.__new__() takes no parameters                                                                  
  obj = object.__new__(cls, *args, **kw)                                                                                                                                        
Enter package name [hello]:                                                                                                                                                     
Do you need Identity (usernames/passwords) in this project? [no]                                                                                                                
Selected and implied templates:                                                                                                                                                 
  TurboGears#tgbase      tg base template                                                                                                                                       
  TurboGears#turbogears  web framework                                                                                                                                          

Variables:
  egg:               hello
  elixir:            False
  identity:          none 
  package:           hello
  project:           hello
  sqlalchemy:        False
  sqlobject:         True 
  sqlobjectversion:  SQLObject>=0.10.1
Creating template tgbase              
Creating directory ./hello            
  Recursing into +einame+.egg-info    
    Creating ./hello/hello.egg-info/  
    Copying PKG-INFO to ./hello/hello.egg-info/PKG-INFO
    Copying paster_plugins.txt to ./hello/hello.egg-info/paster_plugins.txt
    Copying sqlobject.txt_tmpl to ./hello/hello.egg-info/sqlobject.txt     
  Recursing into +package+                                                 
    Creating ./hello/hello/                                                
    Copying __init__.py to ./hello/hello/__init__.py                       
    Copying __init__.pyo to ./hello/hello/__init__.pyo                     
    Copying release.py_tmpl to ./hello/hello/release.py                    
    Recursing into static                                                  
      Creating ./hello/hello/static/                                       
      Recursing into css                                                   
        Creating ./hello/hello/static/css/                                 
Skipping file /usr/lib/python2.6/site-packages/turbogears/qstemplates/qsbase/+package+/static/css/empty_tmpl
      Recursing into images                                                                                 
        Creating ./hello/hello/static/images/                                                               
        Copying favicon.ico to ./hello/hello/static/images/favicon.ico                                      
        Copying tg_under_the_hood.png to ./hello/hello/static/images/tg_under_the_hood.png                  
        Copying under_the_hood_blue.png to ./hello/hello/static/images/under_the_hood_blue.png
      Recursing into javascript
        Creating ./hello/hello/static/javascript/
Skipping file /usr/lib/python2.6/site-packages/turbogears/qstemplates/qsbase/+package+/static/javascript/empty_tmpl
    Recursing into templates
      Creating ./hello/hello/templates/
      Copying __init__.py to ./hello/hello/templates/__init__.py
      Copying __init__.pyo to ./hello/hello/templates/__init__.pyo
Creating template turbogears
  Recursing into +package+
    Copying commands.py_tmpl to ./hello/hello/commands.py
    Recursing into config
      Creating ./hello/hello/config/
      Copying __init__.py to ./hello/hello/config/__init__.py
      Copying __init__.pyo to ./hello/hello/config/__init__.pyo
      Copying app.cfg_tmpl to ./hello/hello/config/app.cfg
      Copying log.cfg_tmpl to ./hello/hello/config/log.cfg
    Copying controllers.py_tmpl to ./hello/hello/controllers.py
    Copying json.py_tmpl to ./hello/hello/json.py
    Copying model.py_tmpl to ./hello/hello/model.py
    Recursing into static
      Recursing into css
        Copying style.css to ./hello/hello/static/css/style.css
      Recursing into images
        Copying header_inner.png to ./hello/hello/static/images/header_inner.png
        Copying info.png to ./hello/hello/static/images/info.png
        Copying ok.png to ./hello/hello/static/images/ok.png
    Recursing into templates
      Copying login.kid to ./hello/hello/templates/login.kid
      Copying master.kid to ./hello/hello/templates/master.kid
      Copying welcome.kid to ./hello/hello/templates/welcome.kid
    Recursing into tests
      Creating ./hello/hello/tests/
      Copying __init__.py to ./hello/hello/tests/__init__.py
      Copying __init__.pyo to ./hello/hello/tests/__init__.pyo
      Copying test_controllers.py_tmpl to ./hello/hello/tests/test_controllers.py
      Copying test_model.py_tmpl to ./hello/hello/tests/test_model.py
  Copying README.txt_tmpl to ./hello/README.txt
  Copying dev.cfg_tmpl to ./hello/dev.cfg
  Copying sample-prod.cfg_tmpl to ./hello/sample-prod.cfg
  Copying setup.py_tmpl to ./hello/setup.py
  Copying start-+package+.py_tmpl to ./hello/start-hello.py
  Copying test.cfg_tmpl to ./hello/test.cfg
Running /usr/bin/python setup.py egg_info
Manually creating paster_plugins.txt (deprecated! pass a paster_plugins keyword to setup() instead)
Adding TurboGears to paster_plugins.txt
running egg_info
paster_plugins not set in setup(), but hello.egg-info/paster_plugins.txt exists
writing requirements to hello.egg-info/requires.txt
writing hello.egg-info/PKG-INFO
writing top-level names to hello.egg-info/top_level.txt
writing dependency_links to hello.egg-info/dependency_links.txt
writing entry points to hello.egg-info/entry_points.txt
reading manifest file 'hello.egg-info/SOURCES.txt'
writing manifest file 'hello.egg-info/SOURCES.txt'
[itamar@localhost tg]$


cd hello

[itamar@localhost hello]$ ./start-hello.py
/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/lib/cptools.py:3: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/filters/sessionfilter.py:33: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
/usr/lib/python2.6/site-packages/peak/rules/indexing.py:220: DeprecationWarning: object.__new__() takes no parameters
  return super(BitmapIndex, cls).__new__(cls, engine, expr)
/usr/lib/python2.6/site-packages/sqlobject/converters.py:165: DeprecationWarning: the sets module is deprecated
  from sets import Set, ImmutableSet
/usr/lib64/python2.6/site-packages/dispatch/predicates.py:379: DeprecationWarning: object.__new__() takes no parameters
  return ExprBase.__new__(klass,function,*argexprs)
/usr/lib/python2.6/site-packages/tw/core/view.py:202: DeprecationWarning: object.__new__() takes no parameters
  obj = object.__new__(cls, *args, **kw)
/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/lib/cptools.py:3: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/filters/sessionfilter.py:33: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
/usr/lib/python2.6/site-packages/peak/rules/indexing.py:220: DeprecationWarning: object.__new__() takes no parameters
  return super(BitmapIndex, cls).__new__(cls, engine, expr)
/usr/lib/python2.6/site-packages/sqlobject/converters.py:165: DeprecationWarning: the sets module is deprecated
  from sets import Set, ImmutableSet
/usr/lib64/python2.6/site-packages/dispatch/predicates.py:379: DeprecationWarning: object.__new__() takes no parameters
  return ExprBase.__new__(klass,function,*argexprs)
/usr/lib/python2.6/site-packages/tw/core/view.py:202: DeprecationWarning: object.__new__() takes no parameters
  obj = object.__new__(cls, *args, **kw)
2009-04-22 20:15:56,343 cherrypy.msg INFO CONFIG: Server parameters:
2009-04-22 20:15:56,344 cherrypy.msg INFO CONFIG:   server.environment: development
2009-04-22 20:15:56,344 cherrypy.msg INFO CONFIG:   server.log_to_screen: True
2009-04-22 20:15:56,344 cherrypy.msg INFO CONFIG:   server.log_file:
2009-04-22 20:15:56,344 cherrypy.msg INFO CONFIG:   server.log_tracebacks: True
2009-04-22 20:15:56,345 cherrypy.msg INFO CONFIG:   server.log_request_headers: True
2009-04-22 20:15:56,345 cherrypy.msg INFO CONFIG:   server.protocol_version: HTTP/1.0
2009-04-22 20:15:56,345 cherrypy.msg INFO CONFIG:   server.socket_host:
2009-04-22 20:15:56,345 cherrypy.msg INFO CONFIG:   server.socket_port: 8080
2009-04-22 20:15:56,345 cherrypy.msg INFO CONFIG:   server.socket_file:
2009-04-22 20:15:56,346 cherrypy.msg INFO CONFIG:   server.reverse_dns: False
2009-04-22 20:15:56,346 cherrypy.msg INFO CONFIG:   server.socket_queue_size: 5
2009-04-22 20:15:56,346 cherrypy.msg INFO CONFIG:   server.thread_pool: 10
Unhandled exception in thread started by <bound method Server._start of <cherrypy._cpserver.Server object at 0x22b7390>>
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cpserver.py", line 78, in _start
    Engine._start(self)
  File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cpengine.py", line 110, in _start
    func()
  File "/usr/lib/python2.6/site-packages/turbogears/startup.py", line 245, in startTurboGears
    view.load_engines()
  File "/usr/lib/python2.6/site-packages/turbogears/view/base.py", line 417, in load_engines
    engine = entrypoint.load()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1912, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 1925, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
pkg_resources.DistributionNotFound: Myghty>=1.1




Version-Release number of selected component (if applicable):

TurboGears-1.0.8-2.fc11.noarch

How reproducible:
every time
Comment 1 Itamar Reis Peixoto 2009-04-22 19:39:20 EDT
after a help in fedora-devel irc

yum install python-myghty

after installing python-myghty it's worked fine.


I am able to see a turbogears page in  http://127.0.0.1:8080/

"Your application is now running"

:-)
Comment 2 Toshio Ernie Kuratomi 2009-04-22 20:02:21 EDT
This is a little strange.  At least on F10, I don't see anything in turbogears that requires myghty.  A grep of my site-packages only shows that pylons has a requirement on that.
Comment 3 Luke Macken 2009-06-01 13:18:06 EDT
This occurs when both TurboGears and Pylons are installed, without Myghty.

Pylons provides a myghty plugin on the `python.templating.engines` entry-point, which TurboGears1 loads.

A solution to this would be for the python-pylons package to require python-myghty, even though it has been superceded by python-mako.
Comment 4 Toshio Ernie Kuratomi 2009-06-01 13:25:51 EDT
Couple ways to resolve this:

* python-pylons can Require python-myghty
* python-pylons can strip out the python-myghty engine as myghty is being
superceded by mako.

Reassigning to pylons so kylev can decide what the best course of action is.
Comment 5 Kyle VanderBeek 2009-06-02 17:13:50 EDT
For now I'll likely just add the python-myghty dependency to mitigate the end-user problem.  I'll also update to the final 0.9.7 release from the current RC4.

Later I'll look to see if we can make TurboGears hook pylons differently so it doesn't require this optional template engine.
Comment 6 Fedora Update System 2009-06-05 02:56:46 EDT
python-simplejson-2.0.9-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-simplejson-2.0.9-1.fc11
Comment 7 Bug Zapper 2009-06-09 10:26:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Kyle VanderBeek 2009-06-14 22:09:56 EDT
Update: I'm currently working on the updated python-pylons package to include the myghty dependancy and update to 0.9.7, but the Pylons guys have what looks like a bug in their test suite so it blows up against Beaker-1.3.1 in rawhide.

Rather than do multiple Pylons updates, I'm just going to keep going and kill both birds in one shot.  It'll just take a little longer.
Comment 9 Fedora Update System 2009-07-30 15:31:56 EDT
python-pylons-0.9.7-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/python-pylons-0.9.7-2.fc11
Comment 10 Fedora Update System 2009-07-31 14:04:12 EDT
python-pylons-0.9.7-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-pylons'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8153
Comment 11 Fedora Update System 2009-08-07 00:55:51 EDT
python-pylons-0.9.7-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.