This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 497301 - ServerName not treated as acceptable Host: value
ServerName not treated as acceptable Host: value
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 05:45 EDT by Marek Greško
Modified: 2009-05-12 00:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.3.10-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-11 23:53:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 3167 None None None Never

  None (edit)
Description Marek Greško 2009-04-23 05:45:25 EDT
Description of problem:
After update to cups-1.3.10 I cannot print remote from fedora 8 clients. I did not test other clients. There are none. I get this in server error log:

Clients are setup in client.conf like this:
ServerName serverfqdn
Encryption IfRequested
DefaultPrinter lp



W [23/Apr/2009:10:08:02 +0200] Request from "clientfqdn" using invalid Host
: field "serverfqdn"


Version-Release number of selected component (if applicable):
cups-1.3.10-1.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade cups to 1.3.10.
2. Try to print from fedora 8 client.
3. Cannot print.
  
Actual results:
Cannot print remotely.

Expected results:
Can print remotely.


Additional info:
Comment 1 Tim Waugh 2009-04-23 12:33:19 EDT
You need to add 'ServerAlias clientfqdn', as mentioned in the update notes:

  https://www.redhat.com/archives/fedora-package-announce/2009-April/msg00510.html
  https://admin.fedoraproject.org/updates/F9/FEDORA-2009-3753

Are you still seeing problems after doing that and restarting cups on the server?
Comment 2 Marek Greško 2009-04-24 08:59:31 EDT
Works for me. Thank you.

But I have two questions. Why the ServerName is not known to the server and ServerAlias should be also specified? I would expect cupsd.conf.rpmnew to be created if a configuration change is required. Should not it appear in the next update of cups?
Comment 3 Tim Waugh 2009-04-24 09:19:35 EDT
1. Why ServerName is not sufficient.

It ought to be.  Do you mean that you need to add a 'ServerAlias' line with exactly the same hostname as the 'ServerName' line?

2. Automatic adjustment of cupsd.conf.

I don't think this is possible with rpm.  The exact change needed to preserve compatibility is to add "ServerAlias *" to cupsd.conf, *once*, on upgrade from cups < 1.3.10.  I was unable to find any way to do this.
Comment 4 Marek Greško 2009-04-24 09:56:06 EDT
1. Yes exactly.

2. OK. I accept.
Comment 5 Tim Waugh 2009-04-24 13:08:45 EDT
Reported upstream with patch.
Comment 6 Fedora Update System 2009-04-26 08:51:30 EDT
cups-1.3.10-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/cups-1.3.10-2.fc9
Comment 7 Fedora Update System 2009-04-26 08:52:21 EDT
cups-1.3.10-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/cups-1.3.10-2.fc10
Comment 8 Tim Waugh 2009-04-27 12:15:10 EDT
cups-1.3.10-4.fc10 should now also adjust cupsd.conf automatically.
Comment 9 Fedora Update System 2009-04-27 17:39:44 EDT
cups-1.3.10-4.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4052
Comment 10 Fedora Update System 2009-04-27 17:40:16 EDT
cups-1.3.10-4.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4056
Comment 11 Fedora Update System 2009-05-09 00:05:19 EDT
cups-1.3.10-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-4056
Comment 12 Fedora Update System 2009-05-09 00:14:32 EDT
cups-1.3.10-5.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update cups'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4052
Comment 13 Fedora Update System 2009-05-11 23:53:27 EDT
cups-1.3.10-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-05-12 00:03:43 EDT
cups-1.3.10-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.