Bug 497317 - package verification failures - specfile improvements
package verification failures - specfile improvements
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cyrus-imapd (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Michal Hlavinka
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 07:31 EDT by Karel Volný
Modified: 2013-04-12 16:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 14:16:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2009-04-23 07:31:44 EDT
Description of problem:
rpm package verification fails due to several reasons that are not an error condition but rather expected behaviour, and so some steps can be taken to prevent false-positives

Version-Release number of selected component (if applicable):
cyrus-imapd-2.3.7-4.el5

How reproducible:
always

Steps to Reproduce:
1. install both 32bit and 64bit cyrus-imapd packages on a multilib system
2. rpm -V cyrus-imapd cyrus-imapd-debuginfo
  
Actual results:
.......T  c /etc/imapd.conf
S.5....T    /usr/lib/debug/usr/bin/imtest.debug
S.5....T    /usr/lib/debug/usr/bin/notifytest.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/arbitron.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/chk_cyrus.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/compile_sieve.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/ctl_cyrusdb.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/ctl_deliver.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/ctl_mboxlist.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/cvt_cyrusdb.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/cyr_expire.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/cyrdump.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/cyrfetchnews.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/cyrus-master.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/deliver.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/fud.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/idled.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/imapd.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/ipurge.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/lmtpd.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/lmtpproxyd.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/make_md5.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/mbexamine.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/mbpath.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/mupdate.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/nntpd.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/notifyd.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/pop3d.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/proxyd.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/ptdump.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/ptexpire.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/ptloader.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/quota.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/reconstruct.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/sievec.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/smmapd.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/squatter.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/sync_client.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/sync_reset.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/sync_server.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/timsieved.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/tls_prune.debug
S.5....T    /usr/lib/debug/usr/lib/cyrus-imapd/unexpunge.debug
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/autosieve.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/backend.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/compile_sieve.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/ctl_cyrusdb.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/ctl_mboxlist.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/imapd.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/lmtp_sieve.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/lmtpd.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/lmtpengine.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/mailbox.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/mailbox.h
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/make_md5.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/mboxlist.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/mboxlist.h
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/message.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/mupdate.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/nntpd.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/pop3d.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/sync_reset.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/imap/sync_server.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/auth.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/auth.h
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/auth_krb5.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/auth_pts.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/auth_unix.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/chartable.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/imapopts.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/imapopts.h
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/libcyr_cfg.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/lib/libcyr_cfg.h
.......T    /usr/src/debug/cyrus-imapd-2.3.7/master/master.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/master/message_uuid_master.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/notifyd/notify_sms.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/notifyd/notifyd.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/notifyd/notifyd.h
.......T    /usr/src/debug/cyrus-imapd-2.3.7/perl/imap/IMAP.c
.......T    /usr/src/debug/cyrus-imapd-2.3.7/perl/sieve/managesieve/managesieve.c


Expected results:
no verification problem reported for /etc/imapd.conf and the source files

Additional info:
the file /etc/imapd.conf is modified within the postinstallation scriptlet, and so the date simply cannot be the same as the distribution date within the package - thus it should be used something like %verify(not mtime) /etc/imapd.conf

the source files are expected to be the same for all the packages sharing the same sources ... but due to patching, the build time sneaks into the binary packages ... I suggest using -T option of patch, so that the timestamp matches for both architecture versions, and also that the user looking at the sources see their last change date which is more interesting for examination and comparison of the sources than the binary build date ...
Comment 1 RHEL Product and Program Management 2009-04-24 04:07:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 errata-xmlrpc 2009-06-22 14:16:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1120.html
Comment 9 Simon Matter 2009-06-23 04:42:44 EDT
I'm not sure the fix works as expected. On my test system the following doesn't work

find . -mtime 0 -print0 | xargs -0 --no-run-if-empty touch -r "%{SOURCE0}"

but if I make it

find . -mtime -1 .....

it seems to work fine.

I'm a bit confused because certain docs state that find -mtime 0 and -1 are the same but somehow that doesn't seem to be true in all cases.

Note You need to log in before you can comment on or make changes to this bug.