Bug 497349 - gtk_entry_set_text is broken in GTK 2.10.4 (and thus in RHEL 5.3)
gtk_entry_set_text is broken in GTK 2.10.4 (and thus in RHEL 5.3)
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2 (Show other bugs)
5.3
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Benjamin Otte
desktop-bugs@redhat.com
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 10:19 EDT by Hugh McCurdy
Modified: 2014-06-25 17:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-25 17:07:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 3551 None None None Never

  None (edit)
Description Hugh McCurdy 2009-04-23 10:19:02 EDT
Description of problem:

RHEL 5.3 contains GTK 2.10.4. gtk_entry_set_text should emit the "changed" signal once but emits it twice. The first emit happens when the function clears the text buffer. The second emit happens after it fills the text buffer. The first one shouldn't happen. The second one should.

This breaks existing applications software. (Which is how I found it)

I believe that this bug is fixed in 2.10.7. (I saw a GTK authored changelog to that effect).  My tests indicate the bug didn't exist in 1.2 and 2.8.20. It also doesn't exist (per my testing) in 2.12.8 and 2.12.9. 


Version-Release number of selected component (if applicable):

2.10.4 of GTK2


How reproducible:

Every time


Steps to Reproduce:
1. You'd have to write a GTK program.  Or you could just trust GTK's changelog for 2.10.7
2.
3.
  
Actual results:

Two signal emissions for "changed."  

Expected results:

One signal emission.


Additional info:

The people at CentOS told me to say that they asked me to post here.

The solution, IMHO, is to update GTK to 2.10.7 or later.  I haven't found any problems with 2.12.9.
Comment 2 Hugh McCurdy 2010-12-21 04:19:19 EST
Did this bug get fixed in RHEL 6?
Comment 3 ritz 2010-12-21 04:38:16 EST
@Hugh

  EL6 ships with gtk2-2.18.9-4.el6, and consequently should be fixed. If otherwise, feel free to escalate this to support (http://www.redhat.com/support/).

Cheers
Comment 4 Hugh McCurdy 2012-10-18 00:41:57 EDT
Hi, I just wanted to report that, based on my tests, the bug has indeed been fixed as of 6.2 (if not sooner).  Thank you.
Comment 7 RHEL Product and Program Management 2014-03-07 07:13:54 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 8 Hugh McCurdy 2014-03-08 12:00:32 EST
Hi, since RHEL 6.x has been released (with the library bug fixed), I have no need or desire to have this bug fixed in the final version of RHEL 5.x.
Comment 9 Ondrej Vasik 2014-06-25 17:07:09 EDT
Ok, closing WONTFIX for RHEL 5, thanks for reply.

Note You need to log in before you can comment on or make changes to this bug.