Bug 497364 - up2date : Unable to fetch requested Package
up2date : Unable to fetch requested Package
Status: CLOSED DUPLICATE of bug 489328
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks: 490076
  Show dependency treegraph
 
Reported: 2009-04-23 11:08 EDT by Petr Sklenar
Modified: 2013-01-10 05:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 10:15:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2009-04-23 11:08:36 EDT
Description of problem:
there is some traceback during downloading/installing packages

Version-Release number of selected component (if applicable):
up2date-4.8.1-33.el4
rhnlib-2.1.4-5.el4

How reproducible:
always on that machine dell-pe1950-01.rhts.englab.brq.redhat.com

Steps to Reproduce:
1. system is connected to RHN proxy, rhn proxy is connected to rhn.webqa via authenticated proxy server
2. up2date aspell*
3. there is traceback with packages aspell-it + aspell-nl
  
Actual results:
Unable to fetch requested

Expected results:
can download/install, no traceback


Additional info:
[root@dell-pe1950-01 ~]# up2date -d aspell-nl aspell-it

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
aspell-it                               0.53                1                   x86_64
aspell-nl                               0.50                5                   x86_64


Testing package set / solving RPM inter-dependencies...
########################################
aspell-it-0.53-1.x86_64.rpm ########################## Done.                   
error: rpmts_HdrFromFdno: MD5 digest: BAD Expected(8067cc921b2342667d73d28899c639e9) != (fff3894af588d816a99e9f57a46a5538)
aspell-nl-0.50-5.x86_64.rpm  An error has occurred:
Unable to fetch requested Package
See /var/log/up2date for more information


[root@dell-pe1950-01 ~]# tail -n 30 /var/log/up2date

[Thu Apr 23 11:03:26 2009] up2date updating login info
[Thu Apr 23 11:03:26 2009] up2date logging into up2date server
[Thu Apr 23 11:03:28 2009] up2date successfully retrieved authentication token from up2date server
[Thu Apr 23 11:03:28 2009] up2date availablePackageList from network
[Thu Apr 23 11:03:37 2009] up2date Unable to fetch requested Package
[Thu Apr 23 11:03:37 2009] up2date   File "/usr/sbin/up2date", line 1315, in ?
    sys.exit(main() or 0)
   File "/usr/sbin/up2date", line 816, in main
    fullUpdate, dryRun=options.dry_run))
   File "/usr/sbin/up2date", line 1163, in batchRun
    batch.run()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 96, in run
    self.__getPackages()
   File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 252, in __getPackages
    up2date.getPackage(pkg, wrapperUtils.printPkg, wrapperUtils.printRetrieveHash)
   File "/usr/share/rhn/up2date_client/up2date.py", line 180, in getPackage
    buf = rpcServer.doCall(repos.getPackage, pkg, msgCallback, progressCallback)
   File "/usr/share/rhn/up2date_client/rpcServer.py", line 238, in doCall
    ret = apply(method, args, kwargs)
   File "/usr/share/rhn/up2date_client/repoDirector.py", line 37, in getPackage
    return self.handlers[channel['type']].getPackage(pkg, msgCallback, progressCallback)
   File "/usr/share/rhn/up2date_client/rpmSource.py", line 186, in getPackage
    package = source.getPackage(pkg, MsgCallback, progressCallback)
   File "/usr/share/rhn/up2date_client/repoBackends/up2dateRepo.py", line 206, in getPackage
    raise up2dateErrors.InvalidRedirectionError(e)
Comment 1 Petr Sklenar 2009-04-23 11:10:06 EDT
machine  dell-pe1950-01.rhts.englab.brq.redhat.com is available for using right now. There is standard rhts password, ping me if you don't know.
Comment 2 Petr Sklenar 2009-04-23 11:17:14 EDT
if I try another x8664 machine connected to rhn proxy then it works. Issue is only with that machine dell-pe1950-01.rhts.englab.brq.redhat.com
Comment 10 James Bowes 2009-05-13 10:05:28 EDT
Moving to up2date. The client gets past the header download stage; this looks like the issue up2date/rhnlib had with trying to download more than one rpm at once, and just reusing the old url over again.

I'm unable to find the original bz about this, which is why i'm not just marking it as a dupe.

Note You need to log in before you can comment on or make changes to this bug.