Bug 497369 - [LTC 6.0 FEAT] Lightweight and dynamic cpu/node evacuation [201928]
[LTC 6.0 FEAT] Lightweight and dynamic cpu/node evacuation [201928]
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
high Severity high
: rc
: 6.0
Assigned To: John Feeney
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 525727
  Show dependency treegraph
 
Reported: 2009-04-23 11:20 EDT by IBM Bug Proxy
Modified: 2013-01-10 02:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 15:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 52947 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-04-23 11:20:47 EDT
=Comment: #0=================================================
Emily J. Ratliff <ratliff@austin.ibm.com> - 
1. Feature Overview:
Feature Id:	[201928]
a. Name of Feature:	Lightweight and dynamic cpu/node evacuation
b. Feature Description
Develop a framework to evacuate on demand a group of CPUs in the system so as to hold them in low
power sleep states and save power. This also helps in more granular power versus performance
tradeoffs on large systems.

2. Feature Details:
Sponsor:	Linux Systems Tech
Architectures:
x86_64
ppc64
s390x

Arch Specificity: Purely Common Code
Affects Core Kernel: Yes
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from Upstream
d. Upstream Acceptance:	Submitted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	Patches and discussions:
 Internal prototypes have been tested, will be shared with community by 30 April 09

3. Business Case
Better utilization of Energy Management for customers so they can better control their operating costs.


4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie Glass, sglass@us.ibm.com, 512-838-9284

Technical contact(s):

Vaidyanathan Srinivasan, svaidyan@in.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com
Comment 1 IBM Bug Proxy 2009-05-20 02:20:56 EDT
------- Comment From svaidyan@in.ibm.com 2009-05-20 02:16 EDT-------
Prototype patches and design are discussed in LKML:

http://lkml.org/lkml/2009/5/13/173
Comment 5 John Jarvis 2009-09-15 11:50:17 EDT
IBM, what is the current upstream status of this code?
Comment 6 IBM Bug Proxy 2009-09-15 15:00:27 EDT
------- Comment From sglass@us.ibm.com 2009-09-15 14:57 EDT-------
This code is not upstream yet.  However there has been related LKML discussion.

Andreas Herrmann (AMD)
http://lkml.org/lkml/2009/8/20/190
[RFC][PATCH 0/15] sched: Fix scheduling for multi-node processors

Peter Zijlstra (RedHat)
http://lkml.org/lkml/2009/9/3/140
[RFC][PATCH 00/14] load-balancing and cpu_power -v3

http://lkml.org/lkml/2009/9/3/127
[RFC][PATCH 02/14] sched: SD_PREFER_SIBLING

The above patch series solve the same cross node balancing in different ways.  Solution can be built based on what gets into mainline next.  Peter Z's patch are in development branch of Ingo's tip tree (4th Sep).

Our plan is to support Peter's approach and build on top of that patch stack to achieve the cross node consolidation goal.

We will not be able to make the 2.6.32 merge window because of ongoing redesign/refactoring by Peter Zijlstra.  Hope to have it upstream by 2.6.33.
Comment 7 IBM Bug Proxy 2009-09-30 14:51:02 EDT
------- Comment From sglass@us.ibm.com 2009-09-30 14:49 EDT-------
Since we have been able to get these patches upstream, deferring to RHEL 6.1
Comment 8 John Jarvis 2009-09-30 15:17:24 EDT
setting as CLOSED DEFERRED to match IBM status.
Comment 9 IBM Bug Proxy 2009-11-19 01:10:31 EST
------- Comment From svaidyan@in.ibm.com 2009-11-19 01:04 EDT-------
The lightweight and dynamic cpu/node evacuation builds on cpu offline framework in Linux kernel.  The cpu offline code is being enhanced to provide support for extended H_CEDE feature in POWER platform.

The patches has been discussed in the community and ready for inclusion.
Recent post and discussion:
[PATCH v5 0/4] pseries: Add cede support for cpu-offline
http://lkml.org/lkml/2009/10/30/6

Peter Zijlstra has Acked the arch independent part and Benjamin Herrenschmidt has reviewed the PowerPC arch specific implementation.

However this patch series depends on the in-kernel handling of DLPAR operations
patch set written by Nathan Fontenot that's under discussion currently in the
final stages of discussion in the Linux community.  The links to the latest
discussions are as follows:
http://lkml.org/lkml/2009/10/21/98
http://lkml.org/lkml/2009/10/21/100
http://lkml.org/lkml/2009/10/21/101
http://lkml.org/lkml/2009/10/21/103
http://lkml.org/lkml/2009/10/21/105

Both the patch series is planned for inclusion in 2.6.33.  Will post an update once these hit the development tree.
Comment 10 IBM Bug Proxy 2010-01-27 16:22:05 EST
------- Comment From sglass@us.ibm.com 2010-01-27 16:13 EDT-------
This was replaced by 58077 as the correct way to get this function

Note You need to log in before you can comment on or make changes to this bug.