This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 497375 - [RHEL4.8][Anaconda] AttributeError: can't set attribute
[RHEL4.8][Anaconda] AttributeError: can't set attribute
Status: CLOSED DUPLICATE of bug 497288
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
http://rhts.redhat.com/testlogs/55519...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 11:38 EDT by Jeff Burke
Modified: 2009-04-23 11:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-23 11:47:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2009-04-23 11:38:48 EDT
Description of problem:
 When trying to install RHEL5.4-Server-20090422.nightly x86_64 on gs-bl460cg1-01.rhts.bos.redhat.com anaconda get a traceback

Version-Release number of selected component (if applicable):
RHEL5.4-Server-20090422.nightly 

How reproducible:
always

Steps to Reproduce:
1. Install RHEL5.4-Server-20090422.nightly x86_64 on gs-bl460cg1-01.rhts.bos.redhat.com
  
Actual results:
Running pre-install scripts
Traceback (most recent call first):
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 295, in setAttribute
    setattr(self, key, value)
  File "/usr/lib/anaconda/yuminstall.py", line 203, in __init__
    self.setAttribute('cachedir', '/tmp/cache/')
  File "/usr/lib/anaconda/yuminstall.py", line 544, in doConfigSetup
    root = root, method=self.method)
  File "/usr/lib/anaconda/yuminstall.py", line 504, in __init__
    self.doConfigSetup(root=anaconda.rootPath)
  File "/usr/lib/anaconda/yuminstall.py", line 853, in doInitialSetup
    self.ayum = AnacondaYum(anaconda)
  File "/usr/lib/anaconda/backend.py", line 171, in doRepoSetup
    anaconda.backend.doInitialSetup(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 201, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 124, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 223, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/cmdline.py", line 135, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/bin/anaconda", line 1006, in ?
    anaconda.intf.run(anaconda)
AttributeError: can't set attribute

install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0
	/proc/bus/usb done
	/proc done
	/dev/pts done
	/sys done
	/tmp/ramfs done
	/mnt/source done
	/selinux done
you may safely reboot your system

Expected results:
Distro should install

Additional info:
Last known good nightly was RHEL5.4-Server-20090412.nightly
Comment 1 Chris Lumens 2009-04-23 11:47:45 EDT

*** This bug has been marked as a duplicate of bug 497288 ***

Note You need to log in before you can comment on or make changes to this bug.