Bug 497386 - CLI proxy install fails on rhel4 satellite.
CLI proxy install fails on rhel4 satellite.
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
https://fjs-0-20.rhndev.redhat.com
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-04-23 12:33 EDT by Preethi Thomas
Modified: 2009-08-09 11:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 09:04:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-04-23 12:33:06 EDT
Description of problem:
CLI proxy install fails on rhel4 satellite.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL4-re20090422.0-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1.install rhel4 satellite 530
2. sync tools & proxy channels for rhel4
3. register a rhel4 client
4.  up2date spacewalk-proxy-installer
5. [root@fjs-0-07 ~]# configure-proxy.sh --answer-file=/root/answers.txt 


Actual results:

[root@fjs-0-07 ~]# configure-proxy.sh --answer-file=/root/answers.txt 
Proxy version to activate [0.5]: 0.5
RHN Parent [fjs-0-20.rhndev.redhat.com]: fjs-0-20.rhndev.redhat.com
Traceback email [pthomas@email.com]: pthomas@email.com
Use SSL [1]: 1
CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
Error: File /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT is not readable by nobody user.
[root@fjs-0-07 ~]# cd /usr/share/rhn/
[root@fjs-0-07 rhn]# wget https://fjs-0-20.rhndev.redhat.com/pub/RHN-ORG-TRUSTED-SSL-CERT
--12:18:27--  https://fjs-0-20.rhndev.redhat.com/pub/RHN-ORG-TRUSTED-SSL-CERT
           => `RHN-ORG-TRUSTED-SSL-CERT'
Resolving fjs-0-20.rhndev.redhat.com... 10.10.76.147
Connecting to fjs-0-20.rhndev.redhat.com|10.10.76.147|:443... connected.
ERROR: Certificate verification error for fjs-0-20.rhndev.redhat.com: unable to get local issuer certificate
To connect to fjs-0-20.rhndev.redhat.com insecurely, use `--no-check-certificate'.
Unable to establish SSL connection.
[root@fjs-0-07 rhn]# wget https://fjs-0-20.rhndev.redhat.com/pub/RHN-ORG-TRUSTED-SSL-CERT --no-check-certificate
--12:18:38--  https://fjs-0-20.rhndev.redhat.com/pub/RHN-ORG-TRUSTED-SSL-CERT
           => `RHN-ORG-TRUSTED-SSL-CERT'
Resolving fjs-0-20.rhndev.redhat.com... 10.10.76.147
Connecting to fjs-0-20.rhndev.redhat.com|10.10.76.147|:443... connected.
WARNING: Certificate verification error for fjs-0-20.rhndev.redhat.com: unable to get local issuer certificate
HTTP request sent, awaiting response... 200 OK
Length: 4,992 (4.9K) [text/plain]

100%[====================================>] 4,992         --.--K/s             

12:18:38 (18.52 MB/s) - `RHN-ORG-TRUSTED-SSL-CERT' saved [4992/4992]

[root@fjs-0-07 rhn]# cd
[root@fjs-0-07 ~]# configure-proxy.sh --answer-file=/root/answers.txt 
Proxy version to activate [0.5]: 0.5
RHN Parent [fjs-0-20.rhndev.redhat.com]: fjs-0-20.rhndev.redhat.com
Traceback email [pthomas@email.com]: pthomas@email.com
Use SSL [1]: 1
CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
HTTP Proxy []: 
Regardless of whether you enabled SSL for the connection to the Spacewalk Parent
Server, you will be prompted to generate an SSL certificate.
This SSL certificate will allow client systems to connect to this Spacewalk Proxy
securely. Refer to the Spacewalk Proxy Installation Guide for more information.
Organization [Red Hat]: Red Hat
Organization Unit [Spacewalk]: Spacewalk
Common Name [fjs-0-07.rhndev.redhat.com]: 
City [Raleigh]: Raleigh
State [NC]: NC
Country code [US]: US
Email [pthomas@email.com]: 
API version: 5.3.0 Beta

There was a problem activating the RHN Proxy entitlement:
ERROR: upon entitlement/activation attempt: unknown error - <Fault 1046: 'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'>
Proxy activation failed! Installation interrupted.
API version: 5.3.0 Beta
RHN Proxy successfully deactivated.


Expected results:


Additional info:
Comment 1 Clifford Perry 2009-04-23 13:35:06 EDT
Proxy version to activate [0.5]: 0.5

I expect this is the issue. Can you confirm that your stock answer file say's 0.5 - cos to me to should be 5.3. 

Then - if this answer file is one we provide, let us know, so we can fix it. 

Cliff
Comment 2 Preethi Thomas 2009-04-23 15:54:10 EDT
my answer file did say 0.5.

but I tried to activate again after fixing my answer file I got a different error.

[root@fjs-0-07 ~]# configure-proxy.sh --answer-file=/root/answers.txt 
Proxy version to activate [5.3]: 5.3
RHN Parent [fjs-0-20.rhndev.redhat.com]: fjs-0-20.rhndev.redhat.com
Traceback email [pthomas@email.com]: pthomas@email.com
Use SSL [1]: 1
CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
HTTP Proxy []: 
Regardless of whether you enabled SSL for the connection to the Spacewalk Parent
Server, you will be prompted to generate an SSL certificate.
This SSL certificate will allow client systems to connect to this Spacewalk Proxy
securely. Refer to the Spacewalk Proxy Installation Guide for more information.
Organization [Red Hat]: Red Hat
Organization Unit [Spacewalk]: Spacewalk
Common Name [fjs-0-07.rhndev.redhat.com]: 
City [Raleigh]: Raleigh
State [NC]: NC
Country code [US]: US
Email [pthomas@email.com]: 
API version: 5.3.0 Beta

There was a problem activating the RHN Proxy entitlement:
ERROR: upon entitlement/activation attempt: ERROR: connection issues? <ProtocolError for fjs-0-20.rhndev.redhat.com /rpc/api: 502 Proxy Error>
Proxy activation failed! Installation interrupted.
API version: 5.3.0 Beta
Comment 3 Miroslav Suchý 2009-04-24 09:04:51 EDT
Commenting original bug:
Yes, you should say there 5.3, otherwise you get that error proxy_channel_not_found since we have no 0.5 proxy channel.

commenting #2
I can not reproduce it.

Hint: if you use answer file you may use --non-interactive as well.
Comment 4 Clifford Perry 2009-04-29 14:10:45 EDT
Preethi, can you confirm if this can be re-produced in current 4/24 ISO drop? 

- Is the 'Proxy 502' error still happening on activation?

- Is the answer file still stock '0.5' for version? 

Wish to understand if this is a QA blocker still, or if the 502 error is resolved and this bug needs to track editing/changing the version listed in the answer file we use?

Thanks,
Cliff
Comment 5 Preethi Thomas 2009-04-30 08:53:14 EDT
no I don't get the 502 error on proxy activation now. so not a QA blocker.

but the answer file /usr/share/doc/spacewalk-proxy-installer-0.5.25/ has the proxy version as "0.5"
Comment 6 Miroslav Suchý 2009-04-30 09:04:33 EDT
Which is tracked under 498251. And it is different issue.
Closing this one as notabug.
Comment 7 wes hayutin 2009-07-23 14:50:38 EDT
testplan
check the default proxy answer file ... make sure it defaults to proxy level to 5.3

Note You need to log in before you can comment on or make changes to this bug.