Bug 497401 - LVMError: lvremove failed for swap
LVMError: lvremove failed for swap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:5cd182d14cb3c1f66...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 14:40 EDT by James Laska
Modified: 2013-09-02 02:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 19:08:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (141.86 KB, text/plain)
2009-04-23 14:40 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-04-23 14:40:03 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 370, in lvremove
    raise LVMError("lvremove failed for %s" % lv_name)
  File "/usr/lib/anaconda/storage/devices.py", line 2048, in destroy
    lvm.lvremove(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1561, in leafInconsistencies
    lv.destroy()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1584, in _handleInconsistencies
    leafInconsistencies(leaf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1631, in populate
    self._handleInconsistencies()
  File "/usr/lib/anaconda/storage/__init__.py", line 288, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/iw/autopart_type.py", line 398, in addDrive
    self.storage.reset()
LVMError: lvremove failed for swap
Comment 1 James Laska 2009-04-23 14:40:07 EDT
Created attachment 340982 [details]
Attached traceback automatically from anaconda.
Comment 2 David Lehman 2009-04-24 19:08:51 EDT
This should be fixed in anaconda-11.5.0.48-1. Since I suspect that retest is nearly impossible I'm just going to close this. If you see it again please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.