Bug 497434 - preadv / pwritev system call windup is not correct
preadv / pwritev system call windup is not correct
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 17:10 EDT by Gerd Hoffmann
Modified: 2009-04-27 16:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 16:11:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerd Hoffmann 2009-04-23 17:10:38 EDT
While poking around in the glibc source code I've found another one ;)

There was a last minute ABI change for the syscalls:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=601cc11d054ae4b5e9b5babec3d8e4667a2cb9b5

The syscall windup in sysdeps/unix/sysv/linux/{preadv,pwritev}.c
doesn't reflect that (yet).

I think that code isn't compiled yet in rawhide due to kernel-headers not having the syscall numbers.  That will change when kernel 2.6.31 hits the repo ...
Comment 1 Jakub Jelinek 2009-04-27 16:11:41 EDT
Should be fixed in glibc-2.9.90-22.

Note You need to log in before you can comment on or make changes to this bug.