Bug 497446 - Feature Request from LSI to include the latest patches for scsi_dh_rdac and device mapper in RHEL 5.4
Feature Request from LSI to include the latest patches for scsi_dh_rdac and d...
Status: CLOSED DUPLICATE of bug 489582
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: 5.4
Assigned To: Tom Coughlan
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-23 18:22 EDT by Abdel Sadek
Modified: 2009-05-01 15:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-01 15:00:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch for scsi_dh_rdac.c for RHEL 5.4 (3.43 KB, patch)
2009-04-24 19:23 EDT, Babu Moger
no flags Details | Diff

  None (edit)
Description Abdel Sadek 2009-04-23 18:22:33 EDT
Description of problem:
  This is a Feature Request from LSI to include the latest patches for scsi_dh_rdac and device mapper in RHEL 5.4. LSI(with the help from opensource comminity) has developed few critical fixes for rdac device handler and also device mapper in last couple of months. We think that these patches are not included in in RHEL 5.4 kernel. We want Redhat to pick up these patches. I will attach the patches very soon. Right now I am waiting for Tom Coughlan's response to get access to alpha sources. 

Version-Release number of selected component (if applicable):
RHEL 5.4

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Babu Moger 2009-04-24 19:23:49 EDT
Created attachment 341258 [details]
Proposed patch for scsi_dh_rdac.c for RHEL 5.4 

This patch contains all the latest changes to drivers/scsi/device_handler/scsi_dh_rdac.c file. All these patches are approved by the community.
Comment 2 Chandra Seetharaman 2009-04-24 20:48:24 EDT
Babu,

I am working with Jesse Larrew(jlarrew@redhat.com) in getting RedHat 5.4 synced up with mainline code thru Bugzilla Bug #489582.
Comment 3 Babu Moger 2009-04-24 23:33:23 EDT
Chandra,
 Fine.. Lets sync up on this on Monday. Lets make sure we have all the patches included in RHEL 5.4.
-Babu
Comment 4 Babu Moger 2009-04-27 19:14:33 EDT
As per the discussion I had with Chandra, he will be syncing RHEL 5.4 sources with the mainline sources for scsi_dh_rdac changes.  He will also be adding the latest patch https://www.redhat.com/archives/dm-devel/2009-April/msg00367.html .

I will mark this BZ as duplicate of Bug 489582.
Comment 5 Babu Moger 2009-05-01 15:00:44 EDT
Patches are already sent to Jesse Larrew to integrate the changes into RHEL 5.4.
There is another bug 489582 which is opened for the same reason. I will mark this as duplicate.

*** This bug has been marked as a duplicate of bug 489582 ***

Note You need to log in before you can comment on or make changes to this bug.