Bug 497457 - media check causes DVD to be lost in HVM install
media check causes DVD to be lost in HVM install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Scott Radvan
ecs-bugs
: Documentation
Depends On:
Blocks: 514500
  Show dependency treegraph
 
Reported: 2009-04-23 20:59 EDT by John Levon
Modified: 2015-04-06 23:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-15 02:37:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Levon 2009-04-23 20:59:00 EDT
To quote from
http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=6800822
:

"When installing a RHEL guest the installer will initially ask
to do a CD media check.  This can be selected or skipped.  If
you select the check the media is tested.  When you continue
the install, after the check, the message "The Red Hat 
Enterprise Linux Server CD was not found in any of your CDROM
drives.  Please insert the Red Hat Enterprise Linux Server CD
and press OK to retry".   Pressing OK just brings up this
message dialogue over and over, basically stopping the install
from continuing."

This is with RHEL4.6,5.2,5.3 all on Solaris dom0, Xen 3.1.4 and 3.3.2. virt-install line was:

virt-install -n domu-225 -m `~johnlev/bin/maca domu-225` --hvm --os-type=solaris --os-variant=opensolaris -f /dev/zvol/dsk/export/dom/domu-220-root -r 1024 --vnc -c /rhel53.iso

Nothing can be seen in the qemu log file.
Comment 1 Chris Lumens 2009-05-20 15:48:40 EDT
Could you please verify whether this is still going to be a problem with F11 (which is not released yet, but will be soon)?  If you're not still seeing it there, then we can close this as NEXTRELEASE since it will no longer be a problem in RHEL6.  Thanks.
Comment 2 John Levon 2009-05-20 18:10:54 EDT
Where is an ISO I can test? Is there a particular reason you think this is fixed?
Comment 3 Chris Lumens 2009-05-21 10:29:26 EDT
http://fedoraproject.org/en/get-prerelease is the latest F11 stuff, though keep in mind that due to a pretty major storage rewrite, you may experience some problems with certain partition layouts.  The reason I think this could be fixed is that there were several media check related bugs fixed for F10, including one with the symptoms you are describing.
Comment 4 John Levon 2009-05-27 19:34:41 EDT
It's still present with the Fedora 11 preview I downloaded today.
Comment 5 Chris Lumens 2009-07-06 14:00:51 EDT
For some reason, ejecting the CD/DVD after media check is run causes it to get lost on virt installs.  I believe you have to somehow go back and mark it as attached again after media check in order for the system to see it.
Comment 6 Cole Robinson 2009-10-13 10:50:20 EDT
Reassigning to xen: virt-install/virt-manager aren't doing any deliberate cd connect/eject here after the media check.
Comment 8 Jiri Denemark 2009-10-27 05:34:43 EDT
Well, I don't think this is a Xen bug. There is no way Xen could determine why the CD was ejected. Perhaps because another CD has to be inserted? In such case one needs to run 'xm block-configure' or any GUI equivalent of it to point it to the new ISO.

My opinion on this is that it's just pretty stupid of anaconda to eject a CD after testing it. In non-virtual-non-laptop case it's fine because the CD tray is automatically loaded. But even in non-virtual case when the CD is loaded into a laptop drive which cannot be loaded automatically, one would see the same message and would have to load it manually (which is a real-world equivalent of 'xm block-configure').

So we have two options to fix this:
1) fix the test not to eject a CD
2) document what manual steps should users do using virt-manager/virsh to insert the CD again

I'd vote for the former as I don't see any reason for ejecting a CD after testing it, but I may be just missing something...
Comment 10 Chris Lumens 2009-11-02 16:47:24 EST
> My opinion on this is that it's just pretty stupid of anaconda to eject a CD
> after testing it. In non-virtual-non-laptop case it's fine because the CD tray
> is automatically loaded. But even in non-virtual case when the CD is loaded
> into a laptop drive which cannot be loaded automatically, one would see the
> same message and would have to load it manually (which is a real-world
> equivalent of 'xm block-configure').

Well, the most obvious reason for wanting to eject the CD is because you could be testing the CD install media instead of the DVD install media, and therefore want to run media check on a whole stack of discs instead of just one.  So, as a nicety to the user we eject the current media and prompt for the next one in the set.
Comment 11 Jiri Denemark 2009-11-03 05:37:02 EST
I guess I'm not a normal user. For me, the necessity to manually reinsert ejected media is much more annoying then having to press a button to eject the media when I want to exchange it. Especially considering rack servers which usually come with laptop CD drives with trays that cannot be closed automatically.

Anyway, if you think it's nice to the user and don't want to fix it, we need to document how to insert the media. Where is the best place to document it? I guess it's not xen as we don't want users to interact with xen directly. So is it libvirt for virsh, virt-install, virt-manager or virtualization guide? Or even a combination of some of them?
Comment 12 Chris Lumens 2010-01-06 14:41:30 EST
I'd imagine that the Virtualization Guide would be the best place to discuss this (and other similar) issues.

Note You need to log in before you can comment on or make changes to this bug.