Bug 497458 - Cloning 500 errata into a channel causes extreme server load and eventual 500/ISE
Cloning 500 errata into a channel causes extreme server load and eventual 500...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-04-23 21:04 EDT by Mike McCune
Modified: 2014-05-09 06:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-09 06:38:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2009-04-23 21:04:01 EDT
* Create a clone of RHEL4-AS with NO ERRATA (gold)

* Clone 500 errata to this channel.

* Watch as server load hits 4-5 and http request times out after 5 minutes.

* cry because you have to solve a bug wrt cloning errata.
Comment 1 Clifford Perry 2009-04-24 11:43:57 EDT
Possible dupe of bug 492248. Can you confirm this is same code path you used?

Cliff
Comment 2 Clifford Perry 2009-04-24 11:45:14 EDT
bug 496259 even. The one in comment #1 is a Proxy bug in another tab :)
Comment 3 Justin Sherrill 2009-04-29 18:53:54 EDT
fixed the ISE, don't think i can fix the server load though.  Not without major errata reworking (aka making the errata data structure not suck)

f798111
Comment 4 Michael Mráka 2009-06-23 04:30:47 EDT
Verified. Satellite-5.3.0-RHEL5-re20090619.0-x86_64 + external db

No ISE. Anyway cloning of 1600 erratas took 5 minutes.
Comment 5 John Sefler 2009-08-31 12:49:44 EDT
FAILS staged (Satellite-5.3.0-RHEL5-re20090724.0) with updates from Aug 20, 2009

After 2 minutes of cloning 1617 Errata from the RHEL4 AS base channel, I got an ISE:
 	
500 Error - Internal Server Error


[root@sun-x4200-01 tmp]# tail /var/log/httpd/error_log
[Mon Aug 31 11:46:00 2009] [error] (70007)The timeout specified has expired: ajp_ilink_receive() can't receive header


[root@sun-x4200-01 tmp]# tail /var/log/httpd/ssl_error_log
Mon Aug 31 11:46:00 2009] [error] ajp_read_header: ajp_ilink_receive failed
[Mon Aug 31 11:46:00 2009] [error] (120006)APR does not understand this error code: proxy: read response failed from (null) (*)
[Mon Aug 31 11:46:01 2009] [error] [client 10.11.231.166] File does not exist: /var/www/html/javascript/prototype-1.js, referer: https://sun-x4200-01.rhts.bos.redhat.com/rhn/errata/manage/CloneConfirmSubmit.do
[Mon Aug 31 11:46:01 2009] [error] [client 10.11.231.166] File does not exist: /var/www/html/img/logo.png, referer: https://sun-x4200-01.rhts.bos.redhat.com/rhn/errata/manage/CloneConfirmSubmit.do


On another staged satellite, the page has been "Loading..." for almost an hour.
moving to FAILS_QA
Comment 6 John Sefler 2009-08-31 12:58:50 EDT
On another staged satellite, the page finally loaded after 56 minutes with 1614 cloned errata.  So I was not able to reproduce the error after all.  Someone else should also re-test.
Comment 9 Clifford Perry 2014-05-09 06:38:17 EDT
We have not addressed this specific bug in over 5 years years. This does not seem to have an active customer case with the bug report either. Closing out as wontfix to clear from backlog. 

Please re-open if you disagree and wish further review.

Cliff

Note You need to log in before you can comment on or make changes to this bug.