Bug 497488 - amanda subpackages require only a specific version of amanda, not also release
amanda subpackages require only a specific version of amanda, not also release
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: amanda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On: 497111
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 04:16 EDT by Daniel Novotny
Modified: 2009-04-24 04:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 497111
Environment:
Last Closed: 2009-04-24 04:38:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Novotny 2009-04-24 04:16:29 EDT
+++ This bug was initially created as a clone of Bug #497111 +++

Description of problem:
If no specific release is required, which is the case of amanda-devel, -server and -client subpackages, rpm won't complain if a user tries to update only the base package, or just a subset of subpackages. This can lead to inconsistencies in installed packages and malfunction caused by incompatibility.

Please replace all occurrences of "Requires(pre): amanda = %{version}" with "Requires(pre): amanda = %{version}-%{release}".

Version-Release number of selected component (if applicable):
amanda-2.5.0p2-4
Comment 1 Daniel Novotny 2009-04-24 04:38:38 EDT
fixed in amanda-2.6.0p2-9.fc12

Note You need to log in before you can comment on or make changes to this bug.