Bug 497501 - NFS install fails
NFS install fails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 06:39 EDT by David Woodhouse
Modified: 2010-06-28 08:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:11:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2009-04-24 06:39:11 EDT
When the installer started up (from boot.iso), it spent a long time (and some of my precious paid-for daytime DSL bandwidth) downloading repodata from the Internet.

To add insult to injury it then refused to see my local NFS mirror of rawhide -- I pointed it at it, but was just told that it can't find repodata.xml.

I install vsftpd on the NFS server and pointed the installer at _that_ instead, and it was able to add the repository just fine.

Next I find out if it actually favour the local repository (which I named '00rawhide' to try to make sure it came first in the list), or if it's going to download everything from the Internet even though it's all available locally...
Comment 1 Chris Lumens 2009-04-24 13:54:44 EDT
The first time you tried with the boot.iso, did you use askmethod, or repo=, or what?  boot.iso defaults to using the mirrorlist provided by /etc/yum.repos.d/* for where to get packages, unless you specify otherwise when you start up anaconda.  Can you attach the /tmp/anaconda.log from when it's starting to grab repodata from elsewhere?
Comment 2 David Woodhouse 2009-04-24 19:00:38 EDT
On that machine I didn't use askmethod or repo=. The only option I ever gave was 'vnc'.

I later installed another machine just by booting the installer kernel+initrd, which obviously didn't find local media and asked me where to find the install tree. On _that_ install, NFS worked.

It's adding NFS repositories once you're in the GUI that seems to fail.

The install from FTP succeeded and the system is running now -- the anaconda.log you want isn't actually stored on the installed system anywhere, is it?

This should be easy to reproduce -- boot the installer, and when asked to add repositories point it at a local NFS-exported copy of the rawhide tree.
Comment 3 Bug Zapper 2009-06-09 10:30:45 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Gary Thomas 2009-06-16 18:46:03 EDT
This problem persists in the released version :-(

I installed via boot.iso (my machine only has a CD).  I have a local
copy of the entire Fedora repository, so I tried to point to that via
NFS on the repository information screen.  I used 'edit repository'
to change the fedora repository to point to my NFS directory.  Same
error - "cannot retrieve repository metadata (repomd.xml)"  Hogwash!
Breaking into a shell (Alt-F2), I can see that the directory I specified
*is* mounted as /mnt/source, the file is present and accessible.
Comment 5 Gary Thomas 2009-06-16 19:16:50 EDT
I tried askmethod -> NFS now works, but the repositories are all messed up.
The 'repomd.xml' file in the releases/11/Fedora/i386 tree doesn't match the
actual files there - it actually matches what's in releases/11/Everything/i386

This seems to happen every release - it seems that trying to have a local NFS
copy is bad mojo - I guess we're all supposed to have infinite network resources
for every install...
Comment 6 Bug Zapper 2010-04-27 09:54:39 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2010-06-28 08:11:28 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.