Bug 497515 - glitches in display of rotation information in gnome-display-properties
glitches in display of rotation information in gnome-display-properties
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 08:19 EDT by Peter F. Patel-Schneider
Modified: 2009-05-18 19:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 19:45:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter F. Patel-Schneider 2009-04-24 08:19:16 EDT
Description of problem:

gnome-display-properties does not always display the rotatability information correctly

Version-Release number of selected component (if applicable):

version in F11 rawhide as of 24 April 2009

How reproducible:

always, at lest on a Thinkpad T60p

Steps to Reproduce:
1. use gnome-display-properties to rotate LCD screen
2. accept rotated setup
3.
  
Actual results:

The Rotation menu has no options.
The gnome-display-properties icon dropdown says no rotation possible.

Expected results:

It should be possible to use the Rotation menu or the dropdown to rotate back.

Additional info:

Closing and opening fixes the Rotation menu but not the dropdown.  Doing a null rotation fixes the dropdown.

Note that this is on a system with no xorg.conf, etc., i.e., a stock F11 beta install (updated to 24 April 2009).  The display driver is the radeon driver.
Comment 1 Matthias Clasen 2009-04-27 22:34:00 EDT
Noted upstream here: http://bugzilla.gnome.org/show_bug.cgi?id=578111
Comment 2 Matthias Clasen 2009-04-28 20:25:31 EDT
Fixed in gnome-desktop-2.26.1-2.fc11
Comment 3 Kevin DeKorte 2009-04-29 15:55:36 EDT
Is this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=494633 as well or is that a different problem?
Comment 4 Peter F. Patel-Schneider 2009-04-29 17:06:29 EDT
Different, I think, as 494633 appears to be a persistent and reports two positions.  In this bug the rotation options are temporarily missing (and thus incorrect, but only temporarily).

PS: When is gnome-desktop-2.26.1-2.fc11 expect to hit rawhide?
Comment 5 Peter F. Patel-Schneider 2009-04-29 19:19:55 EDT
Ah ha!  It just did hit, and seems to have fixed the problem.

As far as I am concerned, this bug can be closed.  (Can I do that?)
Comment 6 Matthias Clasen 2009-04-29 21:06:08 EDT
I've put it in MODIFIED, until the package is tagged
Comment 7 Peter F. Patel-Schneider 2009-05-18 19:45:06 EDT
This has been working great in rawhide for a while, so I'm closing my report.

Note You need to log in before you can comment on or make changes to this bug.