Bug 497566 - wdaemon does not support more than one identical tablets
wdaemon does not support more than one identical tablets
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: linuxwacom (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 14:40 EDT by Ping
Modified: 2014-06-16 22:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ping 2009-04-24 14:40:17 EDT
Description of problem:


Version-Release number of selected component (if applicable): wdaemon-0.15-2.fc11


How reproducible: every time with two same model tablets


Steps to Reproduce:
1.   Connect two Intuos3 6x8 onto a running Fedora 11 beta
2.   wdaemon -a > /etc/wdaemon.conf
3.   more /etc/wdaemon.conf

device = 36,/dev/input/wacom-tablets/intuos3-6x8
device = 36,/dev/input/wacom-tablets/intuos3-6x8-3-1

4.   ls -l /dev/input/wacom-tablets

lrwxrwxrwx. 1 root root 10 2009-04-24 11:16 intuos3-6x8 -> ../event15
lrwxrwxrwx. 1 root root 10 2009-04-24 11:16 intuos3-6x8-3-1 -> ../event14
lrwxrwxrwx. 1 root root 10 2009-04-24 11:16 intuos3-6x8-3-2 -> ../event15

5.   /etc/init.d/wdaemon start

Unable to grab device /dev/input/wacom-tablets/intuos3-6x8-3-1 (Device or resource busy)

Note:  I think intuos3-6x8-3-2 should be used in /etc/wdaemon.conf instead of intuos3-6x8.

6.   ls -l /dev/input/uinput-devices

lrwxrwxrwx. 1 root root 10 2009-04-24 11:20 uinput-wacom-intuos3-6x8-tablet -> ../event16

Note:  we should get two links here, one for each tablet.   


This same problem happens on RHEL5.3 with wdaemon-0.14 too.
Comment 1 Aristeu Rozanski 2009-04-24 14:50:25 EDT
Try changing wdaemon.conf to:
device = 36,/dev/input/wacom-tablets/intuos3-6x8-3-2
device = 36,/dev/input/wacom-tablets/intuos3-6x8-3-1
Comment 2 Ping 2009-04-24 16:37:29 EDT
That has been tried.  Only one entry (the same one as reported before) found under /dev/input/uinput-devices.

In fact, this bug should be filed against RHEL5.3 since Fedora 11 doesn't need wdaemon any more. HAL supports hotplug now.  The bug was reported by a linuxwacom user on RHEL5.3.  I don't have RHEL5.3 so I tried it on a Fedora 11 just to get the proper description to report the bug on behalf of the user.
Comment 3 RHEL Product and Program Management 2014-03-07 07:37:17 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 Ping Cheng 2014-03-07 18:34:49 EST
It is ok to close this bug for RHEL5.
Comment 5 RHEL Product and Program Management 2014-06-03 08:36:28 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 6 Ping Cheng 2014-06-16 22:04:41 EDT
Ok, you can close it.
Comment 7 Ping Cheng 2014-06-16 22:06:54 EDT
Ok, you can close it.

Note You need to log in before you can comment on or make changes to this bug.