Bug 497571 - python-urlgrabber not present in rhn-tools channels for RHEL 4, spacewalk-koan has a dependency on it
python-urlgrabber not present in rhn-tools channels for RHEL 4, spacewalk-koa...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Mike McCune
Miroslav Suchý
:
Depends On:
Blocks: 457075 486216
  Show dependency treegraph
 
Reported: 2009-04-24 15:10 EDT by Steve Salevan
Modified: 2009-09-10 14:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:15:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Salevan 2009-04-24 15:10:36 EDT
Description of problem:
If a user attempts to install spacewalk-koan from their rhn-tools channel on a RHEL 4 box, they'll see the following up2date error:

[root@rhel4-i386 ~]# up2date spacewalk-koan

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
spacewalk-koan                          0.1.11         4.el4sat          noarch


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
koan  1.6.3-4.el4sat                     requires python-urlgrabber  

Version-Release number of selected component (if applicable):
530, 4/14 build

How reproducible:
Always

Steps to Reproduce:
1. Subscribe a RHEL4 system to its rhn-tools channel
2. Run up2date spacewalk-koan
  
Actual results:
As above

Expected results:
Package (and python-urlgrabber dependency) installs

Additional info:
Comment 1 Mike McCune 2009-05-06 13:51:04 EDT
dgilmore pushed python-urlgrabber to the appropriate channels in webqa
Comment 2 Clifford Perry 2009-05-06 13:58:48 EDT
https://rhn.webqa.redhat.com/rhn/software/packages/details/Overview.do?pid=478340

Available From:  	 

Red Hat Network Satellite (v5.3 for AS v4 AMD64 / Intel64)
Red Hat Network Satellite (v5.3 for AS v4 s390)
Red Hat Network Satellite (v5.3 for AS v4 s390x)
Red Hat Network Satellite (v5.3 for AS v4 x86)
Red Hat Network Satellite (v5.3 for AS v4 x86) Beta
Red Hat Network Satellite (v5.3 for AS v4 x86_64) Beta
Red Hat Network Tools for RHEL AS (v. 4 for 31-bit IBM S/390)
Red Hat Network Tools for RHEL AS (v. 4 for 64-bit IBM POWER)
Red Hat Network Tools for RHEL AS (v. 4 for 64-bit IBM zSeries)
Red Hat Network Tools for RHEL AS (v.4 for AMD64/Intel EM64T)
Red Hat Network Tools for RHEL AS (v.4 for Itanium)
Red Hat Network Tools for RHEL AS (v.4 for x86)


Errr... to my knowledge/understanding, we *need* to push python-urlgrabber to ALL RHN Tools child channels for koan and spacewalk-koan to function on RHEL 4, 3 and 2.1 Kickstart provisioning. 

At the very least we would need this package pushed to *all* RHEL 4 channels, not just 'AS' product. I expect that we also need to do it for 3 and 2.1. 

Can we please re-review this bug and get with Nanny and/or Rel-Eng to give specific directions on what we need. 

Cliff
Comment 3 Mike McCune 2009-05-07 12:47:11 EDT
* We need to ensure that we get spacewalk-koan, koan, python-urlgrabber in all rhel2/3/4 rhn-tools channels.

* Also need spacewalk-koan and koan in all rhel5 rhn-tools channels.

Detailed list:

** Need spacewalk-koan, koan, python-urlgrabber:

rhn-tools-rhel-2.1-as-i386          
rhn-tools-rhel-2.1-as-ia64          
rhn-tools-rhel-2.1-aw-ia64          
rhn-tools-rhel-2.1-es-i386          
rhn-tools-rhel-2.1-ws-i386          
rhn-tools-rhel-3-as-i386            
rhn-tools-rhel-3-as-ia64            
rhn-tools-rhel-3-as-ppc             
rhn-tools-rhel-3-as-s390            
rhn-tools-rhel-3-as-s390x           
rhn-tools-rhel-3-as-x86_64          
rhn-tools-rhel-3-desktop-i386       
rhn-tools-rhel-3-desktop-x86_64     
rhn-tools-rhel-3-es-i386            
rhn-tools-rhel-3-es-ia64            
rhn-tools-rhel-3-es-x86_64          
rhn-tools-rhel-3-ws-i386            
rhn-tools-rhel-3-ws-ia64            
rhn-tools-rhel-3-ws-x86_64          
rhn-tools-rhel-4-as-i386            
rhn-tools-rhel-4-as-i386-beta       
rhn-tools-rhel-4-as-ia64            
rhn-tools-rhel-4-as-ia64-beta       
rhn-tools-rhel-4-as-ppc             
rhn-tools-rhel-4-as-ppc-beta        
rhn-tools-rhel-4-as-s390            
rhn-tools-rhel-4-as-s390-beta       
rhn-tools-rhel-4-as-s390x           
rhn-tools-rhel-4-as-s390x-beta      
rhn-tools-rhel-4-as-x86_64          
rhn-tools-rhel-4-as-x86_64-beta     
rhn-tools-rhel-4-desktop-i386       
rhn-tools-rhel-4-desktop-i386-beta  
rhn-tools-rhel-4-desktop-x86_64     
rhn-tools-rhel-4-desktop-x86_64-beta
rhn-tools-rhel-4-es-i386            
rhn-tools-rhel-4-es-i386-beta       
rhn-tools-rhel-4-es-ia64            
rhn-tools-rhel-4-es-ia64-beta       
rhn-tools-rhel-4-es-x86_64          
rhn-tools-rhel-4-es-x86_64-beta     
rhn-tools-rhel-4-ws-i386            
rhn-tools-rhel-4-ws-i386-beta       
rhn-tools-rhel-4-ws-ia64            
rhn-tools-rhel-4-ws-ia64-beta       
rhn-tools-rhel-4-ws-x86_64          
rhn-tools-rhel-4-ws-x86_64-beta     
rhn-tools-rhel-4.5.z-as-i386        
rhn-tools-rhel-4.5.z-as-ia64        
rhn-tools-rhel-4.5.z-as-ppc         
rhn-tools-rhel-4.5.z-as-s390        
rhn-tools-rhel-4.5.z-as-s390x       
rhn-tools-rhel-4.5.z-as-x86_64      
rhn-tools-rhel-4.5.z-es-i386        
rhn-tools-rhel-4.5.z-es-ia64        
rhn-tools-rhel-4.5.z-es-x86_64      
rhn-tools-rhel-4.6.z-as-i386        
rhn-tools-rhel-4.6.z-as-ia64        
rhn-tools-rhel-4.6.z-as-ppc         
rhn-tools-rhel-4.6.z-as-s390        
rhn-tools-rhel-4.6.z-as-s390x       
rhn-tools-rhel-4.6.z-as-x86_64      
rhn-tools-rhel-4.6.z-es-i386        
rhn-tools-rhel-4.6.z-es-ia64        
rhn-tools-rhel-4.6.z-es-x86_64      
rhn-tools-rhel-4.7.z-as-i386        
rhn-tools-rhel-4.7.z-as-ia64        
rhn-tools-rhel-4.7.z-as-ppc         
rhn-tools-rhel-4.7.z-as-s390        
rhn-tools-rhel-4.7.z-as-s390x       
rhn-tools-rhel-4.7.z-as-x86_64      
rhn-tools-rhel-4.7.z-es-i386        
rhn-tools-rhel-4.7.z-es-ia64        
rhn-tools-rhel-4.7.z-es-x86_64     

** Need spacewalk-koan, koan:

rhn-tools-rhel-i386-client-5        
rhn-tools-rhel-i386-client-5-beta   
rhn-tools-rhel-i386-server-5        
rhn-tools-rhel-i386-server-5-beta   
rhn-tools-rhel-ia64-server-5        
rhn-tools-rhel-ia64-server-5-beta   
rhn-tools-rhel-ia64-server-5.0.z    
rhn-tools-rhel-ia64-server-5.1.z    
rhn-tools-rhel-ia64-server-5.2.z    
rhn-tools-rhel-ia64-server-5.3.ll   
rhn-tools-rhel-ia64-server-5.3.z    
rhn-tools-rhel-ppc-server-5         
rhn-tools-rhel-ppc-server-5-beta    
rhn-tools-rhel-ppc-server-5.0.z     
rhn-tools-rhel-ppc-server-5.1.z     
rhn-tools-rhel-ppc-server-5.2.z     
rhn-tools-rhel-ppc-server-5.3.z     
rhn-tools-rhel-s390x-server-5       
rhn-tools-rhel-s390x-server-5-beta  
rhn-tools-rhel-s390x-server-5.0.z   
rhn-tools-rhel-s390x-server-5.1.z   
rhn-tools-rhel-s390x-server-5.2.z   
rhn-tools-rhel-s390x-server-5.3.z   
rhn-tools-rhel-x86_64-client-5      
rhn-tools-rhel-x86_64-client-5-beta 
rhn-tools-rhel-x86_64-server-5      
rhn-tools-rhel-x86_64-server-5-beta 
rhn-tools-rhel-x86_64-server-5.0.z  
rhn-tools-rhel-x86_64-server-5.1.z  
rhn-tools-rhel-x86_64-server-5.2.z  
rhn-tools-rhel-x86_64-server-5.3.ll 
rhn-tools-rhel-x86_64-server-5.3.z
Comment 4 Mike McCune 2009-05-07 12:49:57 EDT
Ticket filed:

https://engineering.redhat.com/rt3/Ticket/Display.html?id=40649
Comment 5 Steve Salevan 2009-06-24 16:39:58 EDT
python-urlgrabber is not currently present in any RHEL 3-related channel as per my testing on the WebQA environment.  Moving to FAILS_QA.
Comment 6 Mike McCune 2009-06-25 17:04:11 EDT
koan no longer requires python-urlgrabber.  I suggest we just retest installing spacewalk-koan on RHEL4 because the original failure condition should be gone.
Comment 7 Miroslav Suchý 2009-06-29 11:17:46 EDT
$ ls  /mnt/redhat/devel/candidate-trees/RHN-Tools-5.3.0-*-re20090625.0/*/*/RHNTools/koan* |xargs -L 1 rpm -qpR | grep python-urlgrabber
is empty

[root@vmware141 ~]# up2date -i koan

Fetching Obsoletes list for channel: rhel-i386-as-4...
########################################

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...
########################################

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
koan                                    1.6.6          2.el4sat          noarch


Testing package set / solving RPM inter-dependencies...
########################################
koan-1.6.6-2.el4sat.noarch. ########################## Done.
The package koan-1.6.6-2.el4sat is not signed with a GPG signature.  Aborting...
Package koan-1.6.6-2.el4sat does not have a GPG signature.
 Aborting...
[root@vmware141 ~]# up2date -i koan --nosig

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...

Fetching rpm headers...
########################################

Name                                    Version        Rel
----------------------------------------------------------
koan                                    1.6.6          2.el4sat          noarch


Testing package set / solving RPM inter-dependencies...
########################################
koan-1.6.6-2.el4sat.noarch. ########################## Done.
Preparing              ########################################### [100%]

Installing...
   1:koan                   ########################################### [100%]
[root@vmware141 ~]# rpm -qa |grep url
[root@vmware141 ~]#
Comment 8 Jan Pazdziora 2009-09-04 09:42:01 EDT
Production validated. With RHEL 4 system registered to hosted (prod), installing spacewalk-koan works:

# up2date spacewalk-koan

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...
########################################

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
spacewalk-koan                          0.1.11              12.el4sat           noarch


Testing package set / solving RPM inter-dependencies...
########################################
spacewalk-koan-0.1.11-12.el ########################## Done.                   
koan-1.6.8-2.el4sat.noarch. ########################## Done.                   
Preparing              ########################################### [100%]

Installing...
   1:koan                   ########################################### [100%]
   2:spacewalk-koan         ########################################### [100%]
The following packages were added to your selection to satisfy dependencies:

Name                                    Version        Release
--------------------------------------------------------------
koan                                    1.6.8          2.el4sat            

#

Moving to RELEASE_PENDING.
Comment 9 Brandon Perkins 2009-09-10 14:15:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.