Bug 497576 - iwlagn does not associate
iwlagn does not associate
Status: CLOSED DUPLICATE of bug 476869
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: John W. Linville
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 15:41 EDT by Mauricio Teixeira
Modified: 2009-09-19 17:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-30 13:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauricio Teixeira 2009-04-24 15:41:20 EDT
Card Intel 4965 AG, on RHEL 5.3, does not associate.

# cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 5.3 (Tikanga)

# uname -r
2.6.18-128.el5

# lspci | grep Wireless
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)

# lsmod | grep iwl
iwlagn                 94297  0 
iwlcore                86085  1 iwlagn
mac80211              137545  2 iwlagn,iwlcore
cfg80211               30793  3 iwlagn,iwlcore,mac80211

# iwlist wlan0 scan
Warning: Driver for device wlan0 recommend version 21 of Wireless Extension,
but has been compiled with version 20, therefore some driver features
may not be available...

wlan0     Interface doesn't support scanning : Network is down

# dmesg
iwlagn: iwlwifi-4965-2.ucode firmware file req failed: Reason -2
iwlagn: Could not read microcode: -2

# ln -s /lib/firmware/iwlwifi-4965-1.ucode /lib/firmware/iwlwifi-4965-2.ucode
# ls -l /lib/firmware/iwlwifi-4965*
-rw-r--r-- 1 root root 191336 Jul 26  2007 /lib/firmware/iwlwifi-4965-1.ucode
lrwxrwxrwx 1 root root     20 Apr 24 16:33 /lib/firmware/iwlwifi-4965-2.ucode -> iwlwifi-4965-1.ucode
-rw-r--r-- 1 root root 191332 Jul 14  2007 /lib/firmware/iwlwifi-4965.ucode

# dmesg
PM: Writing back config space on device 0000:03:00.0 at offset 1 (was 40100102, writing 40100106)
iwlagn: Microcode SW error detected.  Restarting 0x2000000.
iwlagn: No space for Tx
iwlagn: Error sending REPLY_TX_PWR_TABLE_CMD: enqueue_hcmd failed: -28
iwlagn: Microcode SW error detected.  Restarting 0x2000000.
wlan0: failed to restore operational channel after scan

# iwconfig wlan0 essid <essid> key <key>
# iwconfig wlan0
Warning: Driver for device wlan0 recommend version 21 of Wireless Extension,
but has been compiled with version 20, therefore some driver features
may not be available...

wlan0     IEEE 802.11  ESSID:"<essid>"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=14 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:<key>
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Comment 1 Mauricio Teixeira 2009-04-27 10:40:43 EDT
Update: I fetch the firmware from Fedora 10 iwl4965-firmware-228.57.2.23-2.noarch, copy to RHEL5.3 machine, and wireless work, even though I still get the wrong version message.

Warning: Driver for device wlan0 recommend version 21 of Wireless Extension,
but has been compiled with version 20, therefore some driver features
may not be available...

New firmware package should fix that, maybe?
Comment 2 John W. Linville 2009-04-30 13:33:54 EDT

*** This bug has been marked as a duplicate of bug 476869 ***
Comment 3 Mauricio Teixeira 2009-04-30 13:37:01 EDT
Sorry, this is not nice. How can you mark this ticket as a duplicate of another bug I don't have access to? It doesn't make sense to me.
Comment 4 John W. Linville 2009-04-30 13:39:15 EDT
You are @redhat.com -- why can't you see it?

At any rate, the package update for rhel 5.4 is already done.  Feel free to download it from Brew if you don't want to wait for it to come through RHN.
Comment 6 Oleg Frayman 2009-09-19 17:46:39 EDT
This is horrible that you can't view a bug that is linked to a closed bug....

btw, this problem does exist in 5.4, I have updated to the latest packages available

Note You need to log in before you can comment on or make changes to this bug.