Bug 497577 - Enblend post errors
Enblend post errors
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: enblend (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bruno Postle
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-24 15:42 EDT by Philippe Troin
Modified: 2010-02-06 19:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-06 19:06:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2009-04-24 15:42:11 EDT
Description of problem:
yum install enblend

says:

  Installing     : enblend                                                  1/1
install-info: warning: no info dir entry in `/usr/share/info/enblend.info'
install-info: warning: no info dir entry in `/usr/share/info/enfuse-focus-stacking.info'
install-info: warning: no info dir entry in `/usr/share/info/enfuse.info'

Version-Release number of selected component (if applicable):
enblend-3.2-2.fc10.x86_64

How reproducible:
Always
Comment 1 Bruno Postle 2009-04-24 19:13:23 EDT
Patch submitted upstream:
https://sourceforge.net/tracker/?func=detail&aid=2780868&group_id=123407&atid=696411
Comment 2 Bruno Postle 2009-08-26 09:38:01 EDT
Closing, patch has been accepted upstream and will be in the next 4.0 release.
Comment 3 Michal Jaegermann 2010-02-06 14:57:29 EST
(In reply to comment #2)
> Closing, patch has been accepted upstream and will be in the next 4.0 release. 

Not really.
.....
  Updating       : enblend-4.0-3.fc13.x86_64                                  38/164 
install-info: warning: no info dir entry in `/usr/share/info/enblend.info'
install-info: warning: no info dir entry in `/usr/share/info/enfuse.info'

This did not work too well.  As a matter of fact
/usr/share/info/enblend.info.gz
/usr/share/info/enfuse.info.gz
are not even close to beeing info files in a usable format. Three info
files enblend.info.gz, enfuse-focus-stacking.info.gz and enfuse.info.gz included 
with enblend-3.2-4.fc12 package were really info despite missing dir entries.
Something went haywire in packaging?
Comment 4 Bruno Postle 2010-02-06 16:46:33 EST
Thanks, the .spec was missing a texinfo BuildRequires.  It should now be ok if you fetch enblend-4.0-4 from koji. The dir entry seems to be ok too, though I would appreciate if you can confirm this.

(Instead of generating an error, the build was silently replacing the info file with a plain text version, so it appeared to install and looked ok with 'less'. This enblend release has been a real pain, hopefully it is ok now)
Comment 5 Michal Jaegermann 2010-02-06 19:06:30 EST
(In reply to comment #4)
> It should now be ok if
> you fetch enblend-4.0-4 from koji.

Yes, it is AFAICS.  Not only no complaints from %post anymore but also 'info enblend' and 'info enfuse' bring an expected documentation with menus, indices and the like (which obviously means that corresponding entries did show up in /usr/share/info/dir).  Thanks!

I guess that we can be optimistic that new packages will appear in upcoming rawhide and that this one can be closed (although for F11 or F12 the issue is still there).

Note You need to log in before you can comment on or make changes to this bug.