Bug 497673 - Nautilus crashes!
Nautilus crashes!
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
10
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-25 21:13 EDT by Amir Hedayaty
Modified: 2015-03-03 17:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 06:52:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amir Hedayaty 2009-04-25 21:13:39 EDT
Description of problem:

I can not open any folder using nautilus!
I have no idea how to track this bug, if there might be something wrong on my computer!

These things work:
* Desktop is displays and looks fine
* nautilus-* work (Sendto, ....)
* nautilus works in non-browser mode
* Property Window also crashes


Version-Release number of selected component (if applicable):
nautilus-2.24.2-3.fc10.x86_64

How reproducible:
run nautilus (in browser mode)
or try to use properties
  

Additional info:
and nautilus -q gives the following message:

--- Hash table keys for warning below:
--> file:///home/amir
--> x-nautilus-desktop:///
--> file:///home/amir/Desktop
--> file:///home

(nautilus:17880): Eel-WARNING **: "nautilus-metafile.c: metafiles" hash table still has 4 elements at quit time (keys above)

(nautilus:17880): Eel-WARNING **: "nautilus-directory.c: directories" hash table still has 4 elements at quit time
Comment 1 Tomáš Bžatek 2009-04-27 07:05:04 EDT
Thank you for the bug report. Unfortunately, without a stack trace from the crash it is impossible to determine what caused the crash. Please see http://fedoraproject.org/wiki/StackTraces for more information about getting a useful stack trace with debugging symbols. Even if you cannot reproduce this crash at will, you can prepare your system now to produce a good stack trace the next time you experience the crash. Thank you.

Be sure to quit nautilus with "nautilus -q" first.

Please also post version of the gvfs package.

Does downgrading to nautilus-2.24.2-2 help? (http://koji.fedoraproject.org/koji/buildinfo?buildID=73499)
Comment 2 Amir Hedayaty 2009-04-27 08:11:45 EDT
gvfs version is gvfs-1.0.3-7.fc10.x86_64
I am using latest versions on FC10.

I do not think downgrading would help (I can test if I have to) but this crash started a few days ago but last time I updated nautilus was 20 days ago.

And here is the stack-trace

(gdb) run 
The program being debugged has been started already.
Start it from the beginning? (y or n) y
Starting program: /usr/bin/nautilus ~
[Thread debugging using libthread_db enabled]
[New Thread 0x7ffff7fb3810 (LWP 32161)]
[New Thread 0x7ffff267f950 (LWP 32162)]
Initializing nautilus-open-terminal extension
seahorse nautilus module initialized
[New Thread 0x7fffeaa95950 (LWP 32165)]
[New Thread 0x7fffea094950 (LWP 32166)]

Program received signal SIGSEGV, Segmentation fault.
0x0000003c916f2bc4 in _gtk_icon_cache_add_icons (cache=0xa74910, 
    directory=<value optimized out>, hash_table=0xd15b40) at gtkiconcache.c:319
319		  n_images = GET_UINT32 (cache->buffer, image_list_offset);
(gdb) thread apply all bt

Thread 4 (Thread 0x7fffea094950 (LWP 32166)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1  0x0000003c8d6023f5 in g_cond_timed_wait_posix_impl (cond=0x7fffec004234, 
    entered_mutex=0x3c8d0e02a8, abs_time=<value optimized out>)
    at gthread-posix.c:242
#2  0x0000003c8ce142bb in g_async_queue_pop_intern_unlocked (queue=0x9f7320, 
    try=0, end_time=0x7fffea093f80) at gasyncqueue.c:365
#3  0x0000003c8ce62329 in g_thread_pool_wait_for_new_task ()
    at gthreadpool.c:220
#4  g_thread_pool_thread_proxy (data=<value optimized out>)
    at gthreadpool.c:254
#5  0x0000003c8ce60d64 in g_thread_create_proxy (data=0xd90c90)
    at gthread.c:635
#6  0x0000003dfe0073da in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#7  0x0000003dfd4e62bd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112

Thread 3 (Thread 0x7fffeaa95950 (LWP 32165)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
---Type <return> to continue, or q <return> to quit--- 
#1  0x0000003c8d6023f5 in g_cond_timed_wait_posix_impl (cond=0x7fffec004234, 
    entered_mutex=0x3c8d0e02a8, abs_time=<value optimized out>)
    at gthread-posix.c:242
#2  0x0000003c8ce142bb in g_async_queue_pop_intern_unlocked (queue=0x9f7320, 
    try=0, end_time=0x7fffeaa94f80) at gasyncqueue.c:365
#3  0x0000003c8ce62329 in g_thread_pool_wait_for_new_task ()
    at gthreadpool.c:220
#4  g_thread_pool_thread_proxy (data=<value optimized out>)
    at gthreadpool.c:254
#5  0x0000003c8ce60d64 in g_thread_create_proxy (data=0xd5c1a0)
    at gthread.c:635
#6  0x0000003dfe0073da in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#7  0x0000003dfd4e62bd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
Current language:  auto; currently asm

Thread 2 (Thread 0x7ffff267f950 (LWP 32162)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 ()
    at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1  0x0000003c8d6023f5 in g_cond_timed_wait_posix_impl (cond=0x7fffec004234, 
    entered_mutex=0x3c8d0e02a8, abs_time=<value optimized out>)
    at gthread-posix.c:242
#2  0x0000003c8ce142bb in g_async_queue_pop_intern_unlocked (queue=0x9f7320, 
---Type <return> to continue, or q <return> to quit---
    try=0, end_time=0x7ffff267ef80) at gasyncqueue.c:365
#3  0x0000003c8ce62329 in g_thread_pool_wait_for_new_task ()
    at gthreadpool.c:220
#4  g_thread_pool_thread_proxy (data=<value optimized out>)
    at gthreadpool.c:254
#5  0x0000003c8ce60d64 in g_thread_create_proxy (data=0x9f8660)
    at gthread.c:635
#6  0x0000003dfe0073da in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#7  0x0000003dfd4e62bd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112

Thread 1 (Thread 0x7ffff7fb3810 (LWP 32161)):
#0  0x0000003c916f2bc4 in _gtk_icon_cache_add_icons (cache=0xa74910, 
    directory=<value optimized out>, hash_table=0xd15b40) at gtkiconcache.c:319
#1  0x0000003c916f950c in theme_list_icons () at gtkicontheme.c:2296
#2  IA__gtk_icon_theme_list_icons (icon_theme=<value optimized out>, 
    context=<value optimized out>) at gtkicontheme.c:1776
#3  0x0000000000437b69 in nautilus_emblem_sidebar_populate (
    emblem_sidebar=0xd35b40) at nautilus-emblem-sidebar.c:939
#4  0x0000000000437e74 in nautilus_emblem_sidebar_init (
    emblem_sidebar=0xd35b40) at nautilus-emblem-sidebar.c:984
#5  0x0000003c8d22c5ba in IA__g_type_create_instance (
---Type <return> to continue, or q <return> to quit---
    type=<value optimized out>) at gtype.c:1674
#6  0x0000003c8d210b3b in g_object_constructor (type=2, 
    n_construct_properties=4160436464, construct_params=0x3c000000)
    at gobject.c:1334
#7  0x0000003c8d21118d in IA__g_object_newv (object_type=14634432, 
    n_parameters=0, parameters=0x0) at gobject.c:1211
#8  0x0000003c8d211cc7 in IA__g_object_new_valist (object_type=14634432, 
    first_property_name=0x0, var_args=0x7fffffffd650) at gobject.c:1274
#9  0x0000003c8d211e0c in IA__g_object_new (object_type=14634432, 
    first_property_name=0x0) at gobject.c:1056
#10 0x000000000043648b in nautilus_emblem_sidebar_create (
    provider=<value optimized out>, window=0xb941d0)
    at nautilus-emblem-sidebar.c:1080
#11 0x0000000000443017 in add_sidebar_panels ()
    at nautilus-navigation-window.c:1585
#12 nautilus_navigation_window_set_up_sidebar ()
    at nautilus-navigation-window.c:852
#13 nautilus_navigation_window_show_sidebar (window=0xb941d0)
    at nautilus-navigation-window.c:1770
#14 0x00000000004432db in nautilus_navigation_window_show (widget=0xb941d0)
    at nautilus-navigation-window.c:1856
#15 0x0000003c8d20b7dd in IA__g_closure_invoke (closure=0xa29590, 
    return_value=0x0, n_param_values=1, param_values=0xd12a40, 
---Type <return> to continue, or q <return> to quit---
    invocation_hint=0x7fffffffd8f0) at gclosure.c:767
#16 0x0000003c8d220dd8 in signal_emit_unlocked_R (node=0x9b4450, detail=0, 
    instance=0xb941d0, emission_return=0x0, instance_and_params=0xd12a40)
    at gsignal.c:3174
#17 0x0000003c8d222b68 in IA__g_signal_emit_valist (instance=0xb941d0, 
    signal_id=<value optimized out>, detail=0, var_args=0x7fffffffdad0)
    at gsignal.c:2977
#18 0x0000003c8d223093 in IA__g_signal_emit (instance=0x2, 
    signal_id=4160436464, detail=1006632960) at gsignal.c:3034
#19 0x0000003c91835bbc in IA__gtk_widget_show (widget=0xb941d0)
    at gtkwidget.c:3003
#20 0x0000000000464345 in nautilus_window_show_window (window=0xb941d0)
    at nautilus-window.c:675
#21 0x000000000046e902 in finish_loading (view=0xd4f640)
    at fm-directory-view.c:8476
#22 0x00000000004b0fdd in call_ready_callbacks_at_idle (
    callback_data=<value optimized out>) at nautilus-directory-async.c:1913
#23 0x0000003c8ce377bb in g_main_dispatch () at gmain.c:2144
#24 IA__g_main_context_dispatch (context=0x9ab5c0) at gmain.c:2697
#25 0x0000003c8ce3af8d in g_main_context_iterate (context=0x9ab5c0, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2778
#26 0x0000003c8ce3b4bd in IA__g_main_loop_run (loop=0x9a0850) at gmain.c:2986
#27 0x0000003c917238a7 in IA__gtk_main () at gtkmain.c:1200
---Type <return> to continue, or q <return> to quit---
#28 0x000000000043f6e1 in main (argc=<value optimized out>, 
    argv=0x7fffffffe348) at nautilus-main.c:596
Current language:  auto; currently c



Thanks for attention, if you need any more information just ask
Comment 3 Amir Hedayaty 2009-05-01 03:33:23 EDT
my BugBuddy raised a bug in gnome Bugzilla for this bug.
http://bugzilla.gnome.org/show_bug.cgi?id=580977
Comment 4 Tomáš Bžatek 2009-05-12 05:54:31 EDT
This really looks like gtk2 icon cache issue.

Can you try updating your icon cache by `for i in /usr/share/icons/*; do gtk-update-icon-cache -f $i; done` under root? (and ignore the errors)

Also, can you try changing your Gnome icon theme to different one and see if it's reproducible?

Also please attach output of `rpm -q gtk2`
Comment 5 Amir Hedayaty 2009-05-12 06:52:56 EDT
Oh My God! 

The first trick fixed it!

Thanks. I do not know what has messed up my icon cache, but this sure fixed it.

Note You need to log in before you can comment on or make changes to this bug.