Bug 497753 - kernel warning after launching printer settings
kernel warning after launching printer settings
Status: CLOSED DUPLICATE of bug 503773
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-26 17:27 EDT by Matthieu Araman
Modified: 2009-06-09 01:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-09 01:03:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthieu Araman 2009-04-26 17:27:49 EDT
Description of problem:
kernel oops after launching printer settings 
Apr 26 23:12:24 matou dbus: Rejected send message, 2 matched rules; type="method_call", sender=":1.107" (uid=4 pid=13075 comm="bluetooth ") interface="org.bluez.Manager" member="DefaultAdapter" error name="(unset)" requested_reply=0 destination="org.bluez" (uid=0 pid=1766 comm="/usr/sbin/bluetoothd "))
Apr 26 23:12:24 matou kernel: lp0: using parport0 (interrupt-driven).
Apr 26 23:12:24 matou kernel: lp0: console ready
Apr 26 23:12:24 matou hp: io/hpmud/pp.c 627: unable to read device-id ret=-1
Apr 26 23:12:24 matou python: io/hpmud/pp.c 627: unable to read device-id ret=-1
Apr 26 23:12:24 matou kernel: ------------[ cut here ]------------
Apr 26 23:12:24 matou kernel: WARNING: at kernel/sysctl.c:2061 unregister_sysctl_table+0xc7/0xfc() (Not tainted)
Apr 26 23:12:24 matou kernel: Hardware name: GA-MA78GM-S2H
Apr 26 23:12:24 matou kernel: Modules linked in: lp fuse sco bridge stp llc bnep l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand powernow_k8 freq_table dm_multipath uinput ppdev ata_generic pata_acpi firewire_ohci k8temp hwmon snd_hda_codec_atihdmi firewire_core pcspkr crc_itu_t snd_hda_codec_realtek i2c_piix4 usb_storage pata_atiixp snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_timer snd joydev soundcore snd_page_alloc parport_pc shpchp r8169 parport wmi mii raid1 radeon drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
Apr 26 23:12:24 matou kernel: Pid: 13080, comm: python Not tainted 2.6.29.1-102.fc11.x86_64 #1
Apr 26 23:12:24 matou kernel: Call Trace:
Apr 26 23:12:24 matou kernel: [<ffffffff8104aa0b>] warn_slowpath+0xbc/0xf0
Apr 26 23:12:24 matou kernel: [<ffffffff81306577>] ? sock_sendmsg+0xcc/0xe5
Apr 26 23:12:24 matou kernel: [<ffffffff811859ba>] ? avc_has_perm+0x5c/0x6e
Apr 26 23:12:24 matou kernel: [<ffffffffa00e33b9>] ? parport_release+0xaa/0x164 [parport]
Apr 26 23:12:24 matou kernel: [<ffffffff811859ba>] ? avc_has_perm+0x5c/0x6e
Apr 26 23:12:24 matou kernel: [<ffffffff8105212a>] unregister_sysctl_table+0xc7/0xfc
Apr 26 23:12:24 matou kernel: [<ffffffffa00e58cd>] parport_device_proc_unregister+0x2d/0x3b [parport]
Apr 26 23:12:24 matou kernel: [<ffffffffa00e3aeb>] parport_unregister_device+0x14/0x131 [parport]
Apr 26 23:12:24 matou kernel: [<ffffffffa017a1b1>] pp_release+0x11c/0x14e [ppdev]
Apr 26 23:12:24 matou kernel: [<ffffffff810d8d02>] __fput+0xf9/0x1a0
Apr 26 23:12:24 matou kernel: [<ffffffff810d8dc6>] fput+0x1d/0x1f
Apr 26 23:12:24 matou kernel: [<ffffffff810d60d1>] filp_close+0x68/0x72
Apr 26 23:12:24 matou kernel: [<ffffffff810d6187>] sys_close+0xac/0xea
Apr 26 23:12:24 matou kernel: [<ffffffff810113ba>] system_call_fastpath+0x16/0x1b
Apr 26 23:12:24 matou kernel: ---[ end trace 1918fa6873012155 ]---
Apr 26 23:12:38 matou kerneloops: Submitted 1 kernel oopses to www.kerneloops.org
Apr 26 23:12:38 matou kerneloops: URL of last kerneloops report: http://www.kerneloops.org/submitresult.php?number=380286


Version-Release number of selected component (if applicable):
system just installed 20090426 with boot.iso 20090424 

How reproducible:


Steps to Reproduce:
1.go to system /administration/orinters
2.give root password when asked for
3.clic on new printer
  
Actual results:
kernel oops submitted, the new printer window appear as usual

Expected results:
no kernel oops

Additional info:
I've no printer directly connected.
My printer is network connected (hp photosmart)
This used to work with rawhide from March and beginning of April

SMolt profile : http://smolts.org/show?uuid=pub_1ba6e4a2-c95f-4e8c-80a9-9144d24d35ac
Comment 1 Chuck Ebbert 2009-04-27 15:09:13 EDT
        if (!--header->parent->count) {
                WARN_ON(1);
                kfree(header->parent);
        }
Comment 2 Chuck Ebbert 2009-06-09 01:03:15 EDT

*** This bug has been marked as a duplicate of bug 503773 ***

Note You need to log in before you can comment on or make changes to this bug.