Bug 497774 - pccard test returns fail while not asked to insert pccard
pccard test returns fail while not asked to insert pccard
Status: CLOSED WONTFIX
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
All Linux
low Severity low
: ---
: ---
Assigned To: Rob Landry
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 03:20 EDT by zhanghaiyan
Modified: 2014-03-25 20:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 14:48:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hts-5.3-17-RHEL5.3-Server-T60.log (98 bytes, text/x-log)
2009-04-27 03:21 EDT, zhanghaiyan
no flags Details
hts-5.3-17-RHEL5.3-Server-T60-result.xml (146.36 KB, text/xml)
2009-04-27 03:22 EDT, zhanghaiyan
no flags Details

  None (edit)
Description zhanghaiyan 2009-04-27 03:20:33 EDT
Description of the problem:
Run pccard test without pccard is inserted, it returns fail result, but didn't ask user to insert pccard.
In log, it report 'Error! Unable to stat Socket 0'

Version:
hts-5.3-17
RHEL5.3-Server-x86_64
laptop-T60

How reproduce:
100%

Steps:
1. Run command 'hts run -t pccard' without pccard is inserted in pc.

Actual result:
It returns fail result, but didn't ask user to insert pccard. In log, it report 'Error! Unable to stat Socket 0'.

Expected result:
It ask user to insert pccard and continue testing.

Note:
Upload out.log and result.xml for reference
Comment 1 zhanghaiyan 2009-04-27 03:21:47 EDT
Created attachment 341395 [details]
hts-5.3-17-RHEL5.3-Server-T60.log
Comment 2 zhanghaiyan 2009-04-27 03:22:07 EDT
Created attachment 341396 [details]
hts-5.3-17-RHEL5.3-Server-T60-result.xml
Comment 3 Rob Landry 2009-07-16 13:01:50 EDT
Working as designed, though it would be a user experience enhancement to offer the user at least one opportunity to install cards at run time.

Adding to the RHEL6 timeframe given the stage we are at with 5.4 release.
Comment 4 Rob Landry 2010-02-26 14:48:13 EST
After creating the patch to add the user prompt so they could insert the cards I've come to the conclusion that this should be closed/wontfix instead.  The reason for that is that if a prompt is added to the pccard test the pccard test will need then be an interactive test purely for the prompt.  So I'm going to go ahead and do that, also dropping the v7-1.1+ flag for the same reason.

Note You need to log in before you can comment on or make changes to this bug.