This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 497781 - Cannot play midi files with totem in F11/Beta
Cannot play midi files with totem in F11/Beta
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 04:21 EDT by Joachim Backes
Modified: 2009-06-13 01:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 04:53:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2009-04-27 04:21:15 EDT
Description of problem:
In F10 I can play midi files with totem. This fails in F11/Beta with an error msg:

The playback of this movie requires a audio/midi decoder plugin which is not installed.

Version-Release number of selected component (if applicable):

gstreamer-plugins-bad-0.10.11-4.fc11.i586
gstreamer-plugins-farsight-0.12.10-2.fc11.i586
totem-gstreamer-2.26.1-2.fc11.i586
gstreamer-0.10.22-3.fc11.i586
gstreamer-python-0.10.14-2.fc11.i586
totem-2.26.1-2.fc11.i586
totem-mozplugin-2.26.1-2.fc11.i586
gstreamer-plugins-flumpegdemux-0.10.15-6.fc11.i586
gstreamer-plugins-base-0.10.22-2.fc11.i586
gstreamer-plugins-ugly-0.10.11-1.fc11.i586
gstreamer-plugins-good-0.10.14-2.fc11.i586
totem-nautilus-2.26.1-2.fc11.i586
gstreamer-tools-0.10.22-3.fc11.i586
PackageKit-gstreamer-plugin-0.4.6-8.fc11.i586
totem-pl-parser-2.26.1-1.fc11.i586
libtimidity-0.1.0-7.fc11.i586
wildmidi-0.2.2-7.fc11.i586
timidity++-2.13.2-18.fc11.i586
wildmidi-libs-0.2.2-7.fc11.i586



How reproducible:
Each time

Steps to Reproduce:
1.Try to open a midi file with totem
2.
3.
  
Actual results:
The playback of this movie requires a audio/midi decoder plugin which is not installed.

Expected results:
Midi file is played

Additional info:

Typo in error msg: ... requires an audio/midi ... :-)
Comment 1 Bastien Nocera 2009-04-27 04:53:19 EDT
Most likely a problem with the gstreamer-plugins-bad packaging. The wildmidi and timidity are usually in that package, which isn't shipped in Fedora.

Contact your provider for that package (and check that gst-inspect lists the plugins as installed).
Comment 2 John Thacker 2009-06-13 01:41:28 EDT
For the person who originally wrote this:

If you look in the changelog for rpmfusion's gstreamer-plugins-bad, you'll find this:

* Sun Mar 29 2009 Hans de Goede <j.w.r.degoede@hhs.nl> 0.10.11-2
- Rebuild for new faad2 and x264
- Enable libass plugin
- Move the midi plugins to the -extras package, so that people who do not
  need / want midi playback support do not have to download 200 MB of
  wavetable instruments. For people who do want this the automatic gstreamer
  plugin install should take care of installing them.

If that's the provider you're using, you'll need to install gstreamer-plugins-bad-extras to get MIDI.

Note You need to log in before you can comment on or make changes to this bug.