This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 497834 - Software product family mapping audit needed
Software product family mapping audit needed
Status: CLOSED WONTFIX
Product: JBoss Customer Support Portal
Classification: Retired
Component: Product Mappings (Show other bugs)
GovernanceBoard
All Linux
high Severity medium
: ---
: ---
Assigned To: JBoss CSP Bug Watch List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 10:01 EDT by John Sanda
Modified: 2011-01-31 12:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-31 12:40:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sanda 2009-04-27 10:01:54 EDT
Description of problem:
There needs to be an audit of the product mapping that are currently defined in AccessRights.java. In addition to sku mappings these mappings are used to determine to what content a user has access. Some of these mappings look incorrect, but input is needed from the business side to determine what is and is not correct. 

Here is one that I came across during testing that seems wrong. I set up a test user with an entitlement (MCT1150) for EAP. In my test database the sku is also mapped to JBoss Hibernate and JBoss Cache, so I expected my user to have access to these as well. It turned out though that my user also had access to Portal Platform, Communications Platform, JBoss Rules, and jBPM even though these products are not mapped to the sku in my database. The products are accessible because of the mappings defined in AccessRights.java.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Spalding 2011-01-31 12:40:20 EST
Bugs are no longer tracked under this classification. CSP is now monitored in 
Other | Customer Portal | Integrated app: JBoss CSP. 

Please refile any current defect records or RFEs under the current 
classification.
Comment 2 David Spalding 2011-01-31 12:48:12 EST
Bugs are no longer tracked under this classification. CSP is now monitored in 
Other | Customer Portal | Integrated app: JBoss CSP. 

Please refile any current defect records or RFEs under the current 
classification.

Note You need to log in before you can comment on or make changes to this bug.