Bug 497844 - RFE: Add possibility to pass option-rom-parameter(s) to qemu
RFE: Add possibility to pass option-rom-parameter(s) to qemu
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 10:30 EDT by Stefan Neufeind
Modified: 2010-03-16 13:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-13 17:15:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Neufeind 2009-04-27 10:30:41 EDT
I tried booting a kvm-machine using libvirt/virsh. Works fine with IDE-disks, but fails if you configure the primary disk to use virtio. To what I've found on the net, it should be possible to boot from a virtio-disk when the "extboot"-option-rom is used. However there seems to be no way to pass an option-rom-parameter using a libvirt-managed configuration (or to use any existing parameter as a workaround). Afaik using virtio instead of ide should offer a fairly good performance-improvement. And my RHEL-guest seems to recognise virtio fine out of the box - if just the bios would try to cleanly boot from the virtio-disk.
Comment 1 Daniel Berrange 2009-04-27 10:44:08 EDT
It isn't neccessary to set any -option-rom parameter. QEMU will automatically load extboot.bin when needed. If this isn't happening, then there's a bug in some other part of the stack. Please provide details of the actual problem you are having booting with Virtio
Comment 2 Stefan Neufeind 2009-04-27 10:55:41 EDT
Output is:

Options: apmbios pcibios eltorito rombios32

[...]

Booting from hard disk
Boot failed: Could not read the boot disk

FATAL: No bootable device



When I attach a secondary partition via virtio (not the boot-partiton) that appears fine in my RHEL-guest. So I assume qemu trying to boot without extboot might be the problem. But I don't know how to pursuade it to do so :-)
Comment 3 Daniel Berrange 2009-11-13 06:18:46 EST
If you are still hitting this problem, can you provide the guest XML configuration from 'virsh dumpxml GUESTNAME', and the associated log file from the time you attempt to start this. ie /var/log/libvirt/qemu/$GUEST.log
Comment 4 Stefan Neufeind 2009-11-13 13:57:54 EST
sorry, can't retest that in my current environment anymore
Comment 5 Daniel Berrange 2009-11-13 17:15:04 EST
Ok, closing on the basis that I know virtio booting works in general now - all our guests default to virtio these days.

Note You need to log in before you can comment on or make changes to this bug.