Bug 497846 - Unmounted volumes still appear to be mounted to gnome desktop.
Unmounted volumes still appear to be mounted to gnome desktop.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 10:38 EDT by Ian Dall
Modified: 2013-03-05 22:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-20 09:28:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Dall 2009-04-27 10:38:01 EDT
Description of problem:
Unmounted volumes still appear to be mounted to gnome desktop.

Version-Release number of selected component (if applicable):

gnome-volume-manager-2.24.0-1

How reproducible:

Always

Steps to Reproduce:
1.Turn of nautilus automounting 
2.Insert memory stick
3.Select volume icon in Disk Mounter applet and click on "mount".
4.Note that volume is mounted with command line "mount" command. Note volume icon appears on desktop.
5.Select volume icon in Disk Mounter applet and click on "unmount".
6.Note that volume is indeed unmounted with command line "mount" command.
7.Hover over volume icon in Disk Mounter and note the tooltip shows that Disk Mounter thinks the volume is still mounted.
8.Attempt to open the volume and note error.
  
Actual results:
Desktop icon for the volume is still present, Nautilus still shows the volume as available and the Disk Mounter applet still thinks the volume is mounted even though it is not. Opening the volume by any of these means shows an error message in a pop up window:
 Could not find "/media/MEMSTICK"

 Please check spelling and try again.


Expected results:
Desktop icon should disappear, Disk Mounter should show an "unmounted" tooltip, Disk Mounter should allow a mount option instead of continuing to only allow the possibility of unmounting an already unmounted volume. Right clicking on the volume icon in the nautilus "places" panel should allow a mount option instead of continuing to only allow the possibility of unmounting an already unmounted volume.


Additional info:

This doesn't seem to be related to having automount turned off.
This used to work, but I am hazy about when it stopped working. Certainly it worked as far back as F8.

I am guessing when I select gnome-volume-manager as the relevant component.
Comment 1 han pingtian 2009-06-09 06:30:27 EDT
It seems that I have reached the same problems.
Maybe this is a configuration problem? If I restart the haldaemon, the icons will
disappear.
Comment 2 Ian Dall 2009-09-16 09:50:14 EDT
This is still present in Fedora 11. It doesn't exhibit its self if I reboot with the Fedora Live CD so it probably IS a configuration issue, but I can't see what.

Additional information:

~ $ /usr/bin/gvfs-mount --list
Drive(0): 40 GB ATA WDC WD400BB-75FJ
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  Volume(0): 40 GB Filesystem
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
Drive(1): Generic USB Flash Disk
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
  Volume(0): MEMSTICK
    Type: GProxyVolume (GProxyVolumeMonitorGdu)
    Mount(0): MEMSTICK -> file:///media/MEMSTICK
      Type: GProxyMount (GProxyVolumeMonitorGdu)
Drive(2): EPSON Stylus Storage
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
Drive(3): MATSHITA DVD-RAM UJ-846S
  Type: GProxyDrive (GProxyVolumeMonitorGdu)
You have new mail in /var/spool/mail/ian
~ $ cat /media/.hal-mtab

The desktop still thinks the MEMSTCK is mounted but it isn't in .hal-mtab. The device has been unmounted and the mount directory /media/MEMSTICK has been removed.

Any help in tracking this down would be appreciated. I've tried dbus-monitor and as far as I can tell things look normal, it is just that the org.gtk.vfs.MountTracker service listMounts is returning the wrong stuff. (Or at least this is how I interpret it. The dbus stuff is pretty opaque to me!
Comment 3 Ian Dall 2009-09-20 09:28:43 EDT
Changing to gvfs since gnome-volume-manager is depreciated.

It turns out that this problem was caused by devkit-disks-daemon crashing (SIGSEGV), which is in turn due to having /var/lib/DeviceKit-disks readonly (because I am running stateless linux). I will raise a separate bug for DeviceKit-disks (because there should be an entry in /etc/rwtab.d for it and it shouldn't SIGSEGV in anycase).

Note You need to log in before you can comment on or make changes to this bug.