Bug 497871 - guest provisioning error libvirtd, conflicting message
guest provisioning error libvirtd, conflicting message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://riverraid.rhndev.redhat.com/r...
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-04-27 12:50 EDT by wes hayutin
Modified: 2009-09-10 15:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-27 12:50:45 EDT
Description of problem:

4/24.1 build
libvirtd is stopped... and then kickstart initiated successfully


- looking for Cobbler at http://riverraid.rhndev.redhat.com/cobbler_api
- reading URL: http://riverraid.rhndev.redhat.com/cblr/svc/op/ks/system/rlx-3-06.rhndev.redhat.com:1
install_tree: http://riverraid.rhndev.redhat.com:80/ty/932pzrO7
libvirtd is stopped
libvirtd needs to be running
D: Sending back response (0, 'Guest kickstart initiated successfully.', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
Comment 1 Mike McCune 2009-04-27 15:06:29 EDT
moving to sat530-ks.
Comment 2 Justin Sherrill 2009-05-04 16:35:34 EDT
4148d0


fixing issue where guest provisioning would show as succesfull even when it had failed
    
    also fixing issue where koan error messages wouldnt show up in the UI, and an issue where the action failing when provisioning a guest wouldnt cause the kickstart session to be
Comment 3 wes hayutin 2009-05-28 11:03:25 EDT
verified 5/21.1

libvirtd needs to be running
D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': 'libvirtd needs to be running'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: closed   db index       /var/lib/rpm/Providename

moves to fail when libvirtd is stopped
Comment 4 Preethi Thomas 2009-07-29 09:53:08 EDT
release pending
install_tree: http://sun-x4200-01.rhts.bos.redhat.com/ty/djSHPv8X
libvirtd is stopped
libvirtd needs to be running
D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': 'libvirtd needs to be running'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packa
Comment 5 Brandon Perkins 2009-09-10 15:25:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.