Bug 497872 - Virt guest provisioning error, mac address conflict
Virt guest provisioning error, mac address conflict
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-04-27 12:54 EDT by wes hayutin
Modified: 2009-09-10 15:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:25:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-04-27 12:54:34 EDT
Description of problem:

4/24.1 build

rhel 5 virt hosted trying to provision xen guest via webui..
gets..

downloading kernel vmlinuz to /var/lib/xen/vmlinuz
url=http://riverraid.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3/vmlinuz
- reading URL: http://riverraid.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3/vmlinuz
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByUUID
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByName
exceptions.RuntimeError
The MAC address you entered conflicts with the physical NIC.
  File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 116, in initiate_guest
    k.run()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 296, in run
    self.virt()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 584, in virt
    return self.net_install(after_download)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 503, in net_install
    after_download(self, profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 582, in after_download
    self.virt_net_install(profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1051, in virt_net_install
    virt_type     =  self.virt_type
   File "/usr/lib/python2.4/site-packages/koan/xencreate.py", line 177, in start_install
    guest.start_install()
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 822, in start_install
    return self._do_install(consolecb, meter, wait)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 838, in _do_install
    self._create_devices(meter)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 736, in _create_devices
    nic.setup(self.conn)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 315, in setup
    raise RuntimeError, _("The MAC address you entered conflicts with the physical NIC.")

D: Sending back response (0, 'Guest kickstart initiated successfully.', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: closed   db index       /var/lib/rpm/Providename
Comment 1 Mike McCune 2009-04-28 13:19:53 EDT
fixed some nastyness in our system record creation and lookups.  should be fixed in next push.
Comment 2 wes hayutin 2009-05-11 14:17:57 EDT
still a problem in 5/7.1
Comment 3 Mike McCune 2009-05-20 13:29:09 EDT
ON_QA
Comment 4 wes hayutin 2009-05-21 14:39:50 EDT
fails..
5/20 build

downloading kernel vmlinuz to /var/lib/xen/vmlinuz
url=http://riverraid.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3/vmlinuz
- reading URL: http://riverraid.rhndev.redhat.com/cobbler/images/ks-rhel-i386-server-5-u3/vmlinuz
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByUUID
libvir: Xen error : Domain not found: xenUnifiedDomainLookupByName
exceptions.RuntimeError
The MAC address you entered conflicts with the physical NIC.
  File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 129, in initiate_guest
    k.run()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 296, in run
    self.virt()
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 584, in virt
    return self.net_install(after_download)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 503, in net_install
    after_download(self, profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 582, in after_download
    self.virt_net_install(profile_data)
   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1051, in virt_net_install
    virt_type     =  self.virt_type
   File "/usr/lib/python2.4/site-packages/koan/xencreate.py", line 177, in start_install
    guest.start_install()
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 822, in start_install
    return self._do_install(consolecb, meter, wait)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 838, in _do_install
    self._create_devices(meter)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 736, in _create_devices
    nic.setup(self.conn)
   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 315, in setup
    raise RuntimeError, _("The MAC address you entered conflicts with the physical NIC.")

D: Sending back response (1, 'Virtual kickstart failed. Koan error.', {'koan': '  File "/usr/share/rhn/spacewalkkoan/spacewalkkoan.py", line 129, in initiate_guest\n    k.run()\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 296, in run\n    self.virt()\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 584, in virt\n    return self.net_install(after_download)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 503, in net_install\n    after_download(self, profile_data)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 582, in after_download\n    self.virt_net_install(profile_data)\n   File "/usr/lib/python2.4/site-packages/koan/app.py", line 1051, in virt_net_install\n    virt_type     =  self.virt_type\n   File "/usr/lib/python2.4/site-packages/koan/xencreate.py", line 177, in start_install\n    guest.start_install()\n   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 822, in start_install\n    return self._do_install(consolecb, meter, wait)\n   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 838, in _do_install\n    self._create_devices(meter)\n   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 736, in _create_devices\n    nic.setup(self.conn)\n   File "/usr/lib/python2.4/site-packages/virtinst/Guest.py", line 315, in setup\n    raise RuntimeError, _("The MAC address you entered conflicts with the physical NIC.")\n'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: Called refresh_rpmlist
Updating package profile
D: local action status:  (0, 'rpmlist refreshed', {})
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))
Comment 5 Justin Sherrill 2009-05-27 15:27:57 EDT
So this should be fixed by bug 501065 which wasn't in the 5/20 build i don't believe.
Comment 6 wes hayutin 2009-06-01 13:04:35 EDT
verified 5/29
Comment 7 Brandon Perkins 2009-09-10 15:25:23 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.