Bug 497878 - autoipd breakage on hubs which return packets
autoipd breakage on hubs which return packets
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
http://avahi.org/ticket/265
:
: 557180 (view as bug list)
Depends On:
Blocks: 516998 554401
  Show dependency treegraph
 
Reported: 2009-04-27 13:35 EDT by Andres Rodriguez
Modified: 2010-06-28 19:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 554401 (view as bug list)
Environment:
Last Closed: 2010-06-28 19:42:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andres Rodriguez 2009-04-27 13:35:36 EDT
Description of problem:

From avahi bug tracker: In the case where you have a system connected to a hub which returns packets to the sender, autoipd always lists every IP address as taken, even when it isn't. The attached patch fixes this problem by ignoring conflicts when the packet is generated by the local address. I cannot think of any downsides to this approach. 

Please see for the patch: http://avahi.org/ticket/265


How reproducible:


Steps to Reproduce:
1. Create qemu with multicast networking
2. Try to assign IP with avahi-autoipd on the machines using the qemu mcast networking
3. Address will never be assigned since it *thinks* someone already has the IP address that autoipd is trying to assign.
Comment 1 Bug Zapper 2009-06-09 10:39:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Karel Volný 2010-01-11 11:15:22 EST
resetting the version to 'rawhide' as the upstream tracker says it is going to be fixed in Avahi 0.6.26 and we still have just 0.6.25 available
Comment 3 Lennart Poettering 2010-01-20 11:48:10 EST
*** Bug 557180 has been marked as a duplicate of this bug. ***
Comment 4 Bug Zapper 2010-03-15 08:34:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Lennart Poettering 2010-06-28 19:42:21 EDT
Fixed upstream now. Will make an upload for Fedora soon.

Note You need to log in before you can comment on or make changes to this bug.