Bug 497890 - loginAuth.pkl issues after install
loginAuth.pkl issues after install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 14:14 EDT by daryl herzmann
Modified: 2010-01-04 03:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 03:38:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daryl herzmann 2009-04-27 14:14:59 EDT
Howdy,

I apologize in advance if I have this filed against the wrong component.  We (Iowa State) have been seeing this issue for a while, but I don't think ever got around to filing a bug on it.  The issue reproduces 100% of the time for us.  The steps to produce.

1. Install rhel5.3 
2. Setup system for local RHN proxy access and register via rhnreg_ks
3. Log onto RHN hosted and subscribe system to child channels like our 
   Iowa State Linux channel and/or desktop workstation channel.
4. YUM is busted with this traceback:

[snip]
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 812, in _getFileRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 291, in _getFile
    start, end, copy_local, checkfunc, text, reget, cache)
  File "/usr/lib/yum-plugins/rhnplugin.py", line 383, in _noExceptionWrappingGet
    timeout=self.timeout
[snip]
  File "/usr/lib/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 156, in connect
    ret = self.connect_ssl()
  File "/usr/lib/python2.4/site-packages/M2Crypto/SSL/Connection.py", line 149, in connect_ssl
    return m2.ssl_connect(self.ssl, self._timeout)
M2Crypto.SSL.SSLError: certificate verify failed

Removing the /var/spool/up2date/loginAuth.pkl file will get yum working again.

thanks,
  daryl
Comment 1 daryl herzmann 2009-07-06 10:35:06 EDT
Easy way to reproduce.  Simply change the channel subscriptions on RHN website and get the traceback on the machine during next yum command.
Comment 2 daryl herzmann 2009-09-04 18:00:07 EDT
Still easy 100% repeater on RHEL5.4
Comment 4 Milan Zazrivec 2009-12-17 08:58:29 EST
For some reason, I'm not able to reproduce the problem, so I'd like
to ask for some more information to be able to move on:

1) What version of RHN Proxy are we talking here?

2) Was the proxy installed via RHN's webui or with a command line installer?

3) Do I understand correctly, that before you subscribe the system
to a child channel, all yum operations work ok; after you subscribe the
system to a child channel you're getting that traceback?
Comment 5 daryl herzmann 2009-12-17 09:04:23 EST
Hello,

Thanks. I don't have the proxy details, but will get those for you.

The issue only appears when I subscribe a system to our custom child channel.  The standard child channels do not trigger this issue.

3.  Yes, all yum operations are fine until after the system is subscribed to a 
    custom child channel on RHN hosted webUI.

daryl
Comment 6 daryl herzmann 2009-12-17 17:52:30 EST
Hello,

Our local RHN proxy admin states the version installed is: 4.2.3

daryl
Comment 7 Milan Zazrivec 2009-12-18 10:47:17 EST
With RHN Proxy 4.2.3 running on RHEL-4.8, custom proxy channel in rhn.redhat.com,
I'm still not able to reproduce the problem. I'd like to ask for some more
details:

1) What's the version of RHEL your RHN Proxy runs on?

2) Could you please share content of /etc/sysconfig/rhn/up2date of the
client machine that reproduces the problem? (you can obfuscate things
like URL's if you wish not to reveal internal information)

3) If possible, content of /etc/sysconfig/rhn/up2date from your RHN Proxy
would be also helpful ...
Comment 8 Milan Zazrivec 2009-12-18 10:58:43 EST
Full traceback from the client reproducing the problem would also help.
Comment 9 Miroslav Suchý 2009-12-18 11:12:40 EST
I would like to summarize steps to reproduce, to be sure we are on same page:

1. on machine A with RHEL 4.8 setup proxy 4.2.3 activated against hosted
2. create custom channel X on hosted
3. push some package to channel X on hosted using rhn_package_manager
4. on machine B with RHEL 5.4, run rhnreg_ks to register through proxy A (Q: does this bug appear too if you user rhn_register?)
5. subscribe machine B to channel X.
6. on machine B you run "yum install zsh" and you will get traceback

We done exactly these steps and were unable to reproduce this bug. If your steps differ somewhere, please let us know.
Comment 10 daryl herzmann 2009-12-21 12:50:11 EST
Oye,  of course, now I can't reproduce it.  Might as well close this and I'll make noise again if I can generate a reproducing case for you folks to try.  Sorry

Note You need to log in before you can comment on or make changes to this bug.