Bug 497904 - Crash on first ypcat
Crash on first ypcat
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: slapi-nis (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 15:27 EDT by Rob Crittenden
Modified: 2009-05-12 20:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.15-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-12 20:29:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested patch (1.97 KB, patch)
2009-04-27 16:31 EDT, Nalin Dahyabhai
no flags Details | Diff

  None (edit)
Description Rob Crittenden 2009-04-27 15:27:53 EDT
Description of problem:

Intermittent crash of slapd server. backtrace is:

(gdb) where
#0  0x00a89743 in strlen () from /lib/libc.so.6
#1  0x0095154f in nis_all_make_cookie (state=cookie_end0, 
    id=0x5eeb4f8 <Address 0x5eeb4f8 out of bounds>, key_index=34) at nis.c:485
#2  0x00952bbb in nis_process_request (state=0x918da10, 
    request_buf=0x93810a8 "\004�M", request_buflen=68, 
    reply_fragment_fn=0x947a00 <dispatch_reply_fragment_connected>, 
    reply_fn=0x947bc0 <dispatch_reply_connected>, cdata=0xb36e7260, 
    client_secure=0, reply_buf=0x9ce14008 "", reply_buf_size=263168, 
    continuation_cookie=0x93b2414) at nis.c:639
#3  0x00948c45 in dispatch_thread (t=0x925aa20) at disp-nis.c:832
#4  0x00955640 in wrap_pthread_starter (p=0x925aa20) at wrap.c:81
#5  0x00927f81 in ?? () from /lib/libnspr4.so
#6  0x00bd532f in start_thread () from /lib/libpthread.so.0
#7  0x00af220e in clone () from /lib/libc.so.6

Version-Release number of selected component (if applicable):

slapi-nis-0.10-1.fc9.i386

I built this myself from the fc11 srpm.

How reproducible:

Not every restart but most restarts

Steps to Reproduce:
1. service dirsrv restart
2. ypcat -d example.com -h myhost netgroup
No such map netgroup. Reason: RPC failure on NIS operation
Comment 1 Nalin Dahyabhai 2009-04-27 16:16:32 EDT
Can you attach the map configuration and some sample data?
Comment 2 Nalin Dahyabhai 2009-04-27 16:31:12 EDT
Created attachment 341483 [details]
suggested patch

Can you try the attached patch?  There's an uninitialized pointer bug that I can't reproduce locally, but which is probably causing the error for you.
Comment 3 Rob Crittenden 2009-04-27 16:47:07 EDT
I re-created my tree, was pretty trivial. It indeed was a query that returned no members.

Applying the patch fixed the problem.
Comment 4 Fedora Update System 2009-04-28 11:55:36 EDT
slapi-nis-0.11-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/slapi-nis-0.11-1.fc9
Comment 5 Fedora Update System 2009-04-28 11:55:51 EDT
slapi-nis-0.11-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/slapi-nis-0.11-1.fc10
Comment 6 Fedora Update System 2009-04-28 11:56:05 EDT
slapi-nis-0.11-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/slapi-nis-0.11-1.fc11
Comment 7 Fedora Update System 2009-05-02 12:37:11 EDT
slapi-nis-0.13-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update slapi-nis'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4169
Comment 8 Fedora Update System 2009-05-12 00:09:18 EDT
slapi-nis-0.15-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update slapi-nis'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-4169
Comment 9 Fedora Update System 2009-05-12 20:24:51 EDT
slapi-nis-0.15-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-05-12 20:25:44 EDT
slapi-nis-0.15-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-05-12 20:28:52 EDT
slapi-nis-0.15-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.