Bug 497911 - KeyError: 'sda3' - while attempting to add logical volume without specifying drive
KeyError: 'sda3' - while attempting to add logical volume without specifying ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
ppc Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:34e98c46cbc5601ea...
:
: 501193 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 16:19 EDT by James Laska
Modified: 2013-09-02 02:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 15:26:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (324.23 KB, text/plain)
2009-04-27 16:19 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (262.32 KB, text/plain)
2009-05-05 11:42 EDT, James Laska
no flags Details
anacdump.txt (anaconda-11.5.0.49) (736.96 KB, text/plain)
2009-05-06 09:45 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-04-27 16:19:41 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.47 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/partitioning.py", line 917, in growPartitions
    if not limited[part.name]:
  File "/usr/lib/anaconda/storage/partitioning.py", line 567, in doPartitioning
    growPartitions(disks, partitions)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1005, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1113, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 962, in newCB
    self.editPartition(device, isNew=1)
KeyError: 'sda3'
Comment 1 James Laska 2009-04-27 16:19:45 EDT
Created attachment 341481 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-04-28 11:35:58 EDT
= Steps to reproduce =

On an IBM Power5 ppc64 system with two local disks.

1) Boot rawhide/ppc
2) At disk screen, select "Use entire drive" and select "review partitioning"
3) Proceed to disk partitioning details
4) Delete volume group
5) Delete logical volume sda2
6) Delete '/boot' partition on sdb1 
7) Delete logical volume partition on sdb2
8) Create '/boot' partition on sda
9) Create a logical volume partition of maximum size (do not specify allowable disks) 
10) Create another logical volume partition of maximum size (do not specify allowable disks) 

= Actual Results =
Step #9 creates sdb1 as a logical volume (expected)
Step #10 results in a traceback (expected sda3 to be created)>
Comment 3 James Laska 2009-05-05 11:42:38 EDT
Created attachment 342480 [details]
Attached traceback automatically from anaconda.
Comment 4 James Laska 2009-05-06 09:43:45 EDT
reproduced on a rawhide/x86_64 guest (anaconda-11.5.0.48) using the same procedure outlined in comment#2.
Comment 5 James Laska 2009-05-06 09:45:44 EDT
Created attachment 342645 [details]
anacdump.txt (anaconda-11.5.0.49)

Sorry, failure was reproduced against anaconda-11.5.0.49 in a rawhide/x86_64 kvm guest
Comment 6 Chris Lumens 2009-05-11 13:58:39 EDT
This should be fixed in anaconda-11.5.0.51-1.
Comment 7 Chris Lumens 2009-05-18 10:14:47 EDT
*** Bug 501193 has been marked as a duplicate of this bug. ***
Comment 8 Bug Zapper 2009-06-09 10:40:09 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.