Bug 497922 - pure-ftpd: new version available (1.0.22)
pure-ftpd: new version available (1.0.22)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pure-ftpd (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 17:07 EDT by Jose Pedro Oliveira
Modified: 2009-08-05 16:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 16:53:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jose Pedro Oliveira 2009-04-27 17:07:44 EDT
Version 1.0.22 has just been released.


Additional info:

* Version 1.0.22:
 - the LDAP authentication backend now supports TLS encryption.
 - TLS encryption is supported on data channels.
 - downloads require way less CPU time on platforms with slow mmap() calls.
 - MySQL 5+ stored procedures can now be used in the authentication process.
 - time zones issues should be fixed for good.
 - on-demand directories can now be created with any set of permissions.
 - password scrambling of MySQL 5+ is now supported.
 - a catalan translation has been contributed.
 - spurious disconnections due to some clients keepalive tricks have
been fixed.
 - custom authentication handlers are now informed about the encryption
status of the session.
 - standard-conformance and compatibility with several clients have improved.
 - large files are now supported by default.
 - enhanced support for Solaris.
 - a bunch of bug fixes, optimizations and compatibility with newer
libraries and operating system versions.
 - "ftp" and "anonymous" user names can have passwords if the -E switch (no
anonymous logins) is specified.
 - in compatibility mode, non-dangling symbolic links are now displayed as
if they were regular files/directories.
 - --with-everything now includes privsep.
Comment 1 Aurelien Bompard 2009-04-27 17:13:02 EDT
I just built it, it's been submitted for testing :)
But thanks for the heads-up !
Comment 2 Jose Pedro Oliveira 2009-04-27 17:28:25 EDT
Great :)

(note to self: check the archives of fedora-extras-commits list and the koji's recent build list before opening upgrade requests)
Comment 3 Bug Zapper 2009-06-09 10:40:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jose Pedro Oliveira 2009-08-05 16:52:34 EDT
Closing. Pure-ftpd 1.0.22 is already available in the update repos.

Note You need to log in before you can comment on or make changes to this bug.