Bug 497934 - anaconda needs to set _configdir and kernelLocation for ia64
anaconda needs to set _configdir and kernelLocation for ia64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 19:49 EDT by Doug Chapman
Modified: 2009-06-25 15:27 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-25 15:27:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to set configdir and kernelLocation on ia64 (546 bytes, patch)
2009-04-28 10:04 EDT, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2009-04-27 19:49:48 EDT
Description of problem:
A couple things missing in the booty stuff for ia64.  Patch is attached.

This patch along with the one I submitted the other day (bug 497394) now allow us to install on ia64 again!


Version-Release number of selected component (if applicable):
anaconda-11.5.0.47


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2009-04-28 09:58:08 EDT
Could you please attach the patch?  Thanks.
Comment 2 Doug Chapman 2009-04-28 10:04:12 EDT
Created attachment 341574 [details]
patch to set configdir and kernelLocation on ia64

Oops, sorry, forgot to attach this yesterday.
Comment 3 Chris Lumens 2009-04-28 13:27:09 EDT
Looks like iutil.isEfi doesn't work correctly on ia64, which is what's causing these values to not get set right in the first place.  This should be fixed in the next build of anaconda.  Thanks for the bug report.
Comment 4 Bug Zapper 2009-06-09 10:40:45 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.