Bug 497944 - digikam 0.10.0 fails to save keyword hierarchy in IPTC and XMP tags
digikam 0.10.0 fails to save keyword hierarchy in IPTC and XMP tags
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: digikam (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 22:02 EDT by Russell Harrison
Modified: 2009-09-07 22:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 22:37:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 185805 None None None Never

  None (edit)
Description Russell Harrison 2009-04-27 22:02:04 EDT
Description of problem:
digiKam no longer saves the full tag path in the IPTC keyword values to improve compatability with other programs.  To offset this the developers moved the full tag data into a digiKam namespace of the XMP data.  Unfortunately due to a bug in libkexif this data doesn't get written into the file.

Version-Release number of selected component (if applicable):


How reproducible:
Asign a mul

Steps to Reproduce:
1. Set digiKame to save tag information in the file metadata
2. Assign a multi level tag to a image and apply the changes.
  
Actual results:
Only the last level of the tag is saved to the IPTC keywords.  The full tag information isn't stored anywhere.

Expected results:
The full tag information should get saved to a dedicated digiKam namespace in the XMP data.

Additional info:

The upstream KDE bug indicates that the fix is already in libkexiv2 0.6 but the version included in kdegraphics is 0.5 for both F 10 and rawhide.
Comment 1 Rex Dieter 2009-04-30 09:03:30 EDT
I'll double-check things in the upstream report.

To be clear please,
rpm -q digikam kdegraphics-libs
Comment 2 Russell Harrison 2009-04-30 10:19:15 EDT
(In reply to comment #1) 

My apologies I should have done that in the initial report.

$ rpm -q digikam kdegraphics-libs
digikam-0.10.0-1.fc10.i386
kdegraphics-libs-4.2.2-3.fc10.i386

The same problem is also present in rawhide as well.  I think the fix will require back porting a patch to libkexiv2 0.5 as 0.6 is slated for KDE 4.2.3
Comment 3 Rex Dieter 2009-04-30 10:24:36 EDT
0.6 will be in kde-4.2.3?  Cool, we'll be getting that within some weeks.
Comment 4 Russell Harrison 2009-04-30 12:42:47 EDT
I think I may have to take that back.  I went and looked at the 4.2 branch in KDE's svn and it looks like its still at 0.5.0. :-(
Comment 5 Steven M. Parrish 2009-06-28 19:14:09 EDT
Looks like 4.3rc1 is still using 0.5.0 as well.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Rex Dieter 2009-06-28 19:25:38 EDT
Naw,
$ rpm -q kdegraphics-devel
kdegraphics-devel-4.2.90-1.fc11.x86_64

$ pkg-config --modversion libkexiv2
0.6.0
Comment 7 Steven M. Parrish 2009-09-07 22:27:09 EDT
Ping

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Kevin Kofler 2009-09-07 22:37:41 EDT
Should be fixed by the KDE 4.3.0 update, please reopen if the problem persists.

Note You need to log in before you can comment on or make changes to this bug.