Bug 498037 - virt-manager-0.7.0-4 does not require a SVG capable gtk
virt-manager-0.7.0-4 does not require a SVG capable gtk
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 11:40 EDT by R P Herrold
Modified: 2010-03-16 13:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-05 04:26:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2009-04-28 11:40:47 EDT
Description of problem:

There is a missing SVG handler in the gtk required by virt-manager-0.7.0-4

Version-Release number of selected component (if applicable):

virt-manager-0.7.0-4  (from today's Rawhide)

How reproducible:

Build from SRPM, satisfying all dependencies, in BR mandated order, and all Dep's on install, and the gtk required does not ensure that a needed SVG handler is present

[root@centos-5 ~]# rpm -qa --last | tac | tail -20
gv-3.6.7-1orc                                 Mon 27 Apr 2009 11:07:05 AM EDT
gnutls-devel-1.4.1-3.el5_2.1                  Tue 28 Apr 2009 11:04:45 AM EDT
gnutls-devel-1.4.1-3.el5_2.1                  Tue 28 Apr 2009 11:04:49 AM EDT
gtkglext-libs-1.2.0-9orc                      Tue 28 Apr 2009 11:09:47 AM EDT
gtkglext-devel-1.2.0-9orc                     Tue 28 Apr 2009 11:10:07 AM EDT
gtk-vnc-0.3.8-8orc                            Tue 28 Apr 2009 11:11:40 AM EDT
gtk-vnc-devel-0.3.8-8orc                      Tue 28 Apr 2009 11:11:41 AM EDT
gtk-vnc-python-0.3.8-8orc                     Tue 28 Apr 2009 11:11:41 AM EDT
xen-devel-3.0.3-80.el5_3.2                    Tue 28 Apr 2009 11:13:18 AM EDT
numactl-devel-0.9.8-7.el5                     Tue 28 Apr 2009 11:13:20 AM EDT
parted-devel-1.8.1-23.el5                     Tue 28 Apr 2009 11:13:20 AM EDT
numactl-devel-0.9.8-7.el5                     Tue 28 Apr 2009 11:13:21 AM EDT
xen-devel-3.0.3-80.el5_3.2                    Tue 28 Apr 2009 11:13:21 AM EDT
parted-devel-1.8.1-23.el5                     Tue 28 Apr 2009 11:13:22 AM EDT
xhtml1-dtds-1.0-7.1.1                         Tue 28 Apr 2009 11:13:22 AM EDT
libvirt-0.6.2-2orc                            Tue 28 Apr 2009 11:22:54 AM EDT
libvirt-devel-0.6.2-2orc                      Tue 28 Apr 2009 11:22:56 AM EDT
libvirt-python-0.6.2-2orc                     Tue 28 Apr 2009 11:22:57 AM EDT
python-virtinst-0.400.3-7orc                  Tue 28 Apr 2009 11:24:25 AM EDT
virt-manager-0.7.0-4orc                       Tue 28 Apr 2009 11:24:37 AM EDT
[root@centos-5 ~]#      

Steps to Reproduce:

Build and install as noted.

Attempt to start virt-manager

It dies for the noted reason

Traceback (most recent call last):
  File "/usr/share/virt-manager/virt-manager.py", line 368, in ?
    main()
  File "/usr/share/virt-manager/virt-manager.py", line 312, in main
    gtk.window_set_default_icon_from_file(icon_dir + "/" + appname + "-icon.svg")
GError: Couldn't recognize the image file format for file '/usr/share/virt-manager/pixmaps/virt-manager-icon.svg'

Actual results:

It dies, as the art seems to have shifted to SVG's (which is fine)

Expected results:

A working virt-manager

Additional info:

Please ask and I'll provide as needed.
Comment 1 Mark McLoughlin 2009-05-04 10:49:52 EDT
Strange - virt-manager requires librsvg2 which provides the svg loader

Try running update-gdk-pixbuf-loaders, does that help?

Moving to upstream virt-manager, this seems to be an issue running on RHEL5, not Fedora
Comment 2 R P Herrold 2009-05-04 13:44:55 EDT
I have librsvg2 installed of course

[herrold@centos-5 RPMS]$ rpm -qa librsvg2
librsvg2-2.16.1-1.el5
[herrold@centos-5 RPMS]$ rpm -q --qf '%{name} \t %{arch} \n' librsvg2
librsvg2         x86_64
[herrold@centos-5 RPMS]$ 

and then running the command, I get an error for one arch

[herrold@centos-5 RPMS]$ sudo update-gdk-pixbuf-loaders
usage: update-gdk-pixbuf-loaders host_triplet
[herrold@centos-5 RPMS]$ less `which update-gdk-pixbuf-loaders`
[herrold@centos-5 RPMS]$ less
[herrold@centos-5 RPMS]$ ls /etc/gtk-2.0/
gtkrc  i686-redhat-linux-gnu  x86_64-redhat-linux-gnu
[herrold@centos-5 RPMS]$ sudo update-gdk-pixbuf-loaders x86_64-redhat-linux-gnu
g_module_open() failed for /usr/lib64/gtk-2.0/2.10.0/loaders/svg_loader.so: /usr/lib64/libgsf-1.so.114: undefined symbol: g_assertion_message_expr
[herrold@centos-5 RPMS]$ sudo update-gdk-pixbuf-loaders i686-redhat-linux-gnu
[herrold@centos-5 RPMS]$          

[herrold@centos-5 RPMS]$ rpm -qf /usr/lib64/libgsf-1.so
libgsf-devel-1.14.1-7
[herrold@centos-5 RPMS]$

I can update libgsf and its Requires to RawHide if you wish

Please let me know -- Please ask and I'll provide as needed. 

-- Russ herrold
Comment 3 Mark McLoughlin 2009-05-05 04:26:26 EDT
(In reply to comment #2)

> [herrold@centos-5 RPMS]$ sudo update-gdk-pixbuf-loaders x86_64-redhat-linux-gnu
> g_module_open() failed for /usr/lib64/gtk-2.0/2.10.0/loaders/svg_loader.so:
> /usr/lib64/libgsf-1.so.114: undefined symbol: g_assertion_message_expr

Okay, that looks like your problem. Have you rebuilt libgsf against a newer glib or something?

I'm closing this as NOTABUG, because it looks like a problem with the way you've updated or rebuilt packages, rather than a problem with virt-manager itself.

Note You need to log in before you can comment on or make changes to this bug.