Bug 498070 - Update python-matplotlib in EPEL5
Update python-matplotlib in EPEL5
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-matplotlib (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Jef Spaleta
Fedora Extras Quality Assurance
UpdatePackage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 14:52 EDT by Kent Baxley
Modified: 2010-09-24 09:17 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-24 09:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kent Baxley 2009-04-28 14:52:59 EDT
Description of problem:

Request from customer to update python-matplotlib from python-matplotlib-0.90.1-1.  The main reason is due to license changes.  The latest version or whatever will work is fine, as long as it's newer than 0.90.1-1
Comment 1 Jef Spaleta 2009-04-28 15:57:37 EDT
Uhm,
There are significant API changes in later versions which are guaranteed to break existing plotting scripts.

I'm not against upgrading personally..but I'm not sure I can do it without significant potential disruption to users.

http://matplotlib.sourceforge.net/api/api_changes.html

Just changing to 0.91.0 might be "too big" of an API change for some people.

if I were going to cause an API breakage I would essentially suck it up and sync with Fedora and make it a one time pain for large benefit.

also note that python-basemap would also be affected.

EPEL's standing policy on minimizing disruption makes me hesitant to do a release bump here. Please advise.

-jef
Comment 4 Mark Chappell 2010-09-24 09:17:05 EDT
Bumped quite a while back,

[root@centos55 ~]# rpm -q python-matplotlib
python-matplotlib-0.99.1.2-1.el5

Note You need to log in before you can comment on or make changes to this bug.