Bug 498119 - xinetd init script 'status' does not set return value
xinetd init script 'status' does not set return value
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xinetd (Show other bugs)
5.3
All Linux
low Severity low
: ---
: ---
Assigned To: Vojtech Vitek
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 19:33 EDT by Ian Ward Comfort
Modified: 2015-03-04 18:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-25 04:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch fixes init script status retval (217 bytes, patch)
2009-04-28 19:33 EDT, Ian Ward Comfort
no flags Details | Diff

  None (edit)
Description Ian Ward Comfort 2009-04-28 19:33:25 EDT
Created attachment 341672 [details]
Patch fixes init script status retval

The xinetd init script does not set its return value correctly when invoked with 'status'.  For example, if xinetd is stopped, the return value is 0:

	# service xinetd status
	xinetd is stopped
	# echo $?
	0

The proper return value in this case is 3.  For expected behavior, see [1].  The attached patch fixes the issue.

[1] http://refspecs.linux-foundation.org/LSB_3.2.0/LSB-Core-generic/LSB-Core-generic/iniscrptact.html
Comment 1 Todd Zullinger 2010-05-11 17:00:39 EDT
This appears to be identical to #232887 which was filed against Fedora Core 6 and has been fixed for ages in the Fedora packages (the fix is the same as yours, Ian).  Any reason this rather trivial fix hasn't made it into either RHEL 5.4 or 5.5?
Comment 2 Jan Zeleny 2010-05-13 02:48:42 EDT
I guess it's because there was no extra pressure from customers to get it there. Contacting our support and requesting this fix could help. Otherwise I can't guarantee this will be fixed in RHEL-5.
Comment 8 errata-xmlrpc 2011-05-25 04:39:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0827.html

Note You need to log in before you can comment on or make changes to this bug.