Bug 498141 - new ibus install needs gtk immodules
new ibus install needs gtk immodules
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 00:17 EDT by Jens Petersen
Modified: 2009-05-08 23:59 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.1.0.20090423-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 23:59:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-04-29 00:17:25 EDT
Description of problem:
If I run ibus or scim without a gtk immodule installed then IM no longer works in gtk applications apparently.


Steps to Reproduce:
1. install rawhide
2. enable input method (im)
2. rpm -e ibus-gtk
3. restart desktop
4. use im
  
Actual results:
2. im works
4. im does not work

Expected results:
4. XIM to work under GNOME

Additional info:
Currently ibus.conf hardcodes GTK_IM_MODULE=ibus
and scim.conf should check the available immodules:
but neither seem to work for xim in f11.
Comment 1 Jens Petersen 2009-04-29 00:37:10 EDT
Just confirmed this worked ok in F10 if I remove scim-bridge-gtk for example.
Comment 2 Caius Chance 2009-04-29 20:31:31 EDT
Just confirmed this bug is reproducible in rawhide that updated on 29 Apr 09.
Comment 3 Akira TAGOH 2009-04-29 23:46:48 EDT
Have you installed gtk2-immodules package btw?
Comment 4 Jens Petersen 2009-04-30 03:04:07 EDT
Could we please move im-xim.so back into the main gtk2 package?

Or failing that at least have a separate subpackage for it so that ibus can require it?
Comment 5 Matthias Clasen 2009-04-30 09:10:20 EDT
What do you expect ? You remove the ibus immodule, so of course ibus won't work in gtk applications anymore. How about you don't package the ibus immodule separately instead. Then that scenario (ibus, but not gtk immodule) won't happen either...
Comment 6 Matthias Clasen 2009-04-30 13:39:43 EDT
Split it off into gtk2-immodule-xim
Comment 7 Jens Petersen 2009-04-30 19:28:50 EDT
(In reply to comment #5)
> What do you expect? You remove the ibus immodule, so of course ibus won't work
> in gtk applications anymore.

It is more the other way round maybe I didn't install it :) (think people upgrading from f10 and doing "yum install ibus-anthy" - ping! totally non-working ibus).

> How about you don't package the ibus immodule
> separately instead. Then that scenario (ibus, but not gtk immodule) won't
> happen either...  

Valid point, since ibus GUI requires gtk2 the idea does make some sense.

However what about multilib in that case though?
Our overall package management system is not so good at handling multilib unfortunately.

Moving this to ibus to consider this suggestion.

(In reply to comment #6)
> Split it off into gtk2-immodule-xim  

Thanks!

Huang Peng, can you please make ibus require gtk2-immodule-xim also.
Comment 8 Jens Petersen 2009-04-30 19:32:19 EDT
(In reply to comment #7)
> Valid point, since ibus GUI requires gtk2 the idea does make some sense.
> 
> However what about multilib in that case though?
> Our overall package management system is not so good at handling multilib
> unfortunately.
> 
> Huang Peng, can you please make ibus require gtk2-immodule-xim also.  

Or is it better just to make ibus require ibus-gtk?

That avoids the multilib problem and actually means we don't need xim for gtk ibus.
Comment 9 Peng Huang 2009-05-04 20:24:59 EDT
(In reply to comment #8)
> Or is it better just to make ibus require ibus-gtk?
> 
> That avoids the multilib problem and actually means we don't need xim for gtk
> ibus.  

How to deal KDE users? Maybe they don't like dependences on gtk. Later, maybe ibus-qt will be ready. Should we add ibus require ibus-qt also?
Comment 10 Jens Petersen 2009-05-04 21:01:01 EDT
(In reply to comment #9)
> How to deal KDE users? Maybe they don't like dependences on gtk. Later, maybe
> ibus-qt will be ready. Should we add ibus require ibus-qt also?  

Doesn't ibus require gtk currently anyway?
Comment 11 Peng Huang 2009-05-04 21:32:00 EDT
Currently, ibus panel requires gtk. But ideally we should develop another panel on qt for KDE desktop.

For this bug, I suggest we just make sure the default installation or upgrading will include ibus-gtk. We need not consider users remove the im module by self.

Jens, Can we let anaconda install ibus-gtk during the upgrading?
Comment 12 Jens Petersen 2009-05-04 21:57:29 EDT
(In reply to comment #11)
> Currently, ibus panel requires gtk. But ideally we should develop another panel
> on qt for KDE desktop.

I know but as long as the main ibus packages depend on gtk2 I don't so a problem with pulling ibus-gtk too.  When the gtk code is 

> For this bug, I suggest we just make sure the default installation or upgrading
> will include ibus-gtk. We need not consider users remove the im module by self.

Problems is I don't know how to do that, unless they choose to install ibus at system upgrade time from anaconda.

Otherwise I suggested ibus to require gtk2-immodules-xim but then easier to just require ibus-gtk I guess. :)

> Jens, Can we let anaconda install ibus-gtk during the upgrading?  

We don't install ibus for upgrades in f11 by default, users will be upgraded to latest scim in f11 from f10.
Comment 13 Jens Petersen 2009-05-04 21:59:28 EDT
I meant:

> I know but as long as the main ibus packages depend on gtk2 I don't so a
> problem with pulling ibus-gtk too.  When the gtk code is 

as long as the main ibus packages depend on gtk2 I don't see a
problem with pulling in ibus-gtk too.  If/when the gtk code is
separated we can drop that dependency from the main package at
the same time.
Comment 14 Peng Huang 2009-05-04 22:16:30 EDT
Actually, it just looks weird. Anyway, I added the require in ibus. I think we could close this bug now.
Comment 15 Fedora Update System 2009-05-04 22:22:46 EDT
ibus-1.1.0.20090423-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-1.1.0.20090423-2.fc11
Comment 16 Fedora Update System 2009-05-08 23:59:44 EDT
ibus-1.1.0.20090423-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.